1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Cannot copy folder from external USB drive

By Squiggly1 ยท 4 replies
Apr 12, 2009
  1. I backed up my failing computer's documents & settings data to an external USB drive. I completely reinstalled a (new) version of XP Home Edition on the computer. Now when I try to copy and paste the folder from by USB drive to my C drive I instantly get an error message "Cannot copy file". I tried unchecking "read only" for the folder and all of it's contents. That didn't work. In fact after I click "OK" and view the folder properties, "read only" is back to the checked state again. I suspect this is something to do with NTFS permissions or something. When booting with an Ubuntu live CD I can't even VIEW the drive, as it's saying that the USB drive is "locked". What is the workaround to copy it off my external drive back to my new C drive?
     
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

  3. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Is the USB drive physically locked? Like one of those "lock" switches on sandisks...
    If you are copying it, all you would need to do is read, and I think that read only box is always check, everything on my computer is read only, not that I can't write or modify.
     
  4. Squiggly1

    Squiggly1 TS Rookie Topic Starter Posts: 44

    I took a closer look. Everything copies fine except MicroSoft Word files with long file names. I am not even able to copy from Volume D to Volume C. Right clicking these stubborn files doesn't even show the copy option. Strange! I read about cancopy.net but the site is shut down. Perhaps there's another software out there that allows you to copy files with long file names?

    UPDATE: Apparently this is related to a bug with Windows. After doing some reading I think the solution is to use the command prompt's XCOPY command. Since DOS ignores long files (by renaming them to short names) it just goes ahead a copies. What a pain in the **** it has been to zero in on this problem! I've spent hours trying to figure this one out.
     
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Thanks for that update! :grinthumb

    Had a chance to learn something new myself from it!! :)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...