Cannot Uninstall Programs

By MaylaJam
Oct 18, 2008
Topic Status:
Not open for further replies.
  1. I have two computers from different family members and neither can uninstall programs. One computer the option to uninstall is missing. The other computer freezes when uninstalling. I've tried to restore on computer one and was able to get the uninstall option back but when I try to uninstall it freezes and I lose the option again. Computer one happen when we were trying to uninstall google toolbar. The other happen when a message popped up doing surfing that it had viruses, trying to sell a product.
  2. tw0rld

    tw0rld TechSpot Maniac Posts: 609   +6

  3. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    Most programs will not uninstall if they're running:

    You will need to make sure though that it does not start when you boot, or it will not allow the uninstall:

    Start> Run> type in ''msconfig' without the quotes> Selective Start-up> Startup tab> uncheck the process that is for this> Apply> OK.

    Reboot> Close the nag message that comes up after checking 'don't show this message again'.

    Now do the uninstall in the Control Panel> Add/Remove Programs.
  4. KINGMEET

    KINGMEET Newcomer, in training Posts: 31

    Use ccleaner as an unistall tool.

    With ccleaner its way eaiser to
    stop and start progams at start-up and unistall programs.

    Its under the tool section.


    Moderator Comment


    KINGMEET I have removed a number of your support posts

    As they have either:
    Not been supportive
    Double (and in some cases triple Posting the same thing)
    Or abusive with excessive capitalization

    Do not continue this
  5. xzibid

    xzibid Newcomer, in training

  6. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    I rarely send a 'newbie' to do a regedit. What we do need from you MaylaJam, is more information on just what is happening and what you are doing:

    1. Did you stop the program you want to uninstall first, reboot, then try the uninstall?
    2. Are you looking first to see if the program has it's own uninstaller?

    "One computer the option to uninstall is missing. The other computer freezes when uninstalling." Since we're working with two different systems, let's try and define each problem"
    1. Compute 1- missing option to uninstall> where is it missing from? What happens?
    2. Computer 2- have your checked the Event Viewer to see if there is an Error that corresponds to this 'freeze'? Do you get any message at all when it 'freezes'?
    3. You have not given us any information about either of the computers. This is like looking for a black coat in a closet with the door shut and no light!
    Please give Operating System, Installed RAM and processor type for each system.

    Re #2, the Event Viewer- Description:
    Unfortunately, many Windows XP users aren't aware of the Event Viewer, what it is, where it is, how it can help with a problem: The Event Viewer has logs for everything that happens on the computer. It has logs for Applications. It has logs for the System and it has logs for Security Audit.

    There are three types of Events in the System and Apps logs:
    1. Information (white circle w/blue i): this is just basic documentation of the normal working of the System or Apps.
    2. Warnings (yellow triangle w/black exclamation mark) noting some problem at that moment. Warnings usually resolve on their own. If they do not, they become>>>
    3. Errors (red circle w/white X- they document something that didn't work or isn't happening as it should. Each Errors has three parts: an ID#, a Source and a Description. By doing a right click> Properties, the Error will open to a screen that can be copied. These three parts taken together can usually lead to cause and resolution.

    There are three sets of logs: System, Applications and Security. By opening the first two to display the Events, you can look for Errors that correspond to the time of the problem.

    The path above is based on Windows XP. IF you are using Vista, the path will be slightly different, but the principal and the outcome are the same.
  7. MaylaJam

    MaylaJam Newcomer, in training Topic Starter

    Computer one is missing from the Add/Remove Programs. It's running Vista Premium. I don't have the option at all to remove. I try restoring it to a previous state, but once I try to uninstall a program, it goes back to the previous and I lose the option to uninstall. I will try CCleaner.

    Computer two - XP, SP2, it states that it is stil running but left on for hours and nothing happens (uninstall). We also don't have the option to restore, it's not highlighted. We tried to reinstall Internet Explorer because we couldn't get into the internet, and it wouldn't go through.

    We did try the CCleaner and uninstall programs from Computer two, We actually bought a virus scan and Windows Washer, to clean out all the system. It did have some viruses, but we still have problems with the computer. The reason I haven't responded, it's because I have not been able to work on the computers directly until later today and this weekend. I will looked at Computer two and find out more information. Thank you.
  8. MaylaJam

    MaylaJam Newcomer, in training Topic Starter

    Computer One

    Here's the lowdown on Computer One. It's running Windows XP SP3, Pentium 4, 2.4 GHz, 1 gb ram. I cleaned out the whole system. Installed and running Firewall, Virus, Spyware, Malware. Scan all the files, uninstalled and remove all clutter. The computer is working very well, is running at super speed, but there is one major problem. Some of the system tools and Internet explorer are working properly. It's the display. I cannot sign on to any website and get a blank page. I open System Restore, blank page. I can't open the System Information page. I go to hotmail, and I get a blank page but I can tell that I am at the webpage. At yahoo, I'm able to sign in, it takes me to the inbox, but only the headings show up, no graphics, no messages. I'm able to connect into the internet. I installed Firefox and it's running perfect, I can get into any website with absoutely no problems.

    System Restore is running, I checked for that. But it's a blank page.
    Also I lost the windows security center link, but I was able to turn on the firewall through control panel. But I decided to run Zone Alarm.

    I'm running Zone Alarm, Webroot Anti-Virus, Windows Washer, Anti-Malware.

    Thank you for any help.
  9. Poppa Bear

    Poppa Bear TechSpot Enthusiast Posts: 266

    Revo Uninstaller

    Just as an afterthought, have you tried Revo uninstaller? I've found this very good for forced uinstall and it's free.

    A link to it's site is... here
  10. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    MaylaJam, will you please run at least Malwarebytes on both computers? That will give us some idea of remaining malware.this isn't the full cleaning and I do understand you have run other security programs:
    Attach the log on your next post.
  11. almcneil

    almcneil TechSpot Guru Posts: 1,554

    Disable ZoneAlarm and see if your web access problems disappear. Zone Alarm is a highly rated firewall but it's tricky.

    Next to that, there's no question you've been infected with spyware. Now I have my fav anti-spyware utilities if you want to try them (all available in the Downloads section at this site):

    1) AVG 8
    2) Ad-Aware 2008
    3) Spybot Search & Destroy

    Repost with results.

    Best,
    -- Andy
  12. MaylaJam

    MaylaJam Newcomer, in training Topic Starter

    I've done everything recommended

    These system tools and I.E. were not working before I installed ZoneAlarm, and I have runned the Malware and Spyware you recommended (Malwarebytes' Anti-Malware, Spybot, Adware) and I come up empty. I have run full scans on the computer of the Malware, Spyware, Virus Scan. Still nothing. It comes out clean.
    I have not tried Revo uninstaller but I did use CCleaner. But after I clean the computer I'm able to uninstall from Windows Add/Remove Programs.

    I have tried to Uninstall and re-install I.E. but it still doesn't work. Thank you.
  13. CCT

    CCT Newcomer, in training Posts: 3,556

    This is THE most screwed up thread in months.

    Start a new Spyware thread about ONE computer and wait for Bobbye to reply.

    thx
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.