TechSpot

Can't access local network anymore

By poertner_1274
Oct 12, 2002
Topic Status:
Not open for further replies.
  1. I haven't had any problems borwsing my network until a few days ago. I did nothing to change and now i can't get on ANY computers on my network, not even any of hte ones in my room. Going directly through the hub, it is strange. Anything I can do to change the situation would be greatly apprecited as I need to get files off a friends computer. Thanks again
    Oh I am running xp pro
  2. Vehementi

    Vehementi TechSpot Paladin Posts: 3,199

    Have you asked your school's network admin for help? He may be messing around with a few things...Changing protocols, etc. etc.

    You could try a Sneakernet :D
  3. Mictlantecuhtli

    Mictlantecuhtli TechSpot Evangelist Posts: 4,916   +9

    XP has this "repair" option for networks, maybe it works..
    Can you ping yourself? Or 127.0.0.1? Are any network protocols suddendly missing?
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,490   +292

    School's network admin wouldn't even touch a problem like this since Poertner lives in a fraternity and the only thing campus does for us is allows us high speed connection to them and the outside world. This is a problem completely isolated from school since he can't even access computers on the fraternity's LAN.
  5. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    Like Michtlan said, try pinging 127.0.0.1, yourself, etc. Goes a little like this.

    Open command prompt. Type "ipconfig":

    Windows 2000 IP Configuration



    Ethernet adapter NTL CABLE:



    Connection-specific DNS Suffix . :
    IP Address. . . . . . . . . . . . : 60.4.134.188

    Subnet Mask . . . . . . . . . . . : 255.255.255.0

    Default Gateway . . . . . . . . . : 60.4.134.254


    First try to ping the loopback address 127.0.0.1 and your own IP address, in this instance 60.4.134.188

    ping 127.0.0.1
    ping 60.4.134.188

    Do you get a reply? If not, then the problem is internal to your own machine. You either have a problem with TCP/IP itself, or your NIC card is not working.... Also, did you check to see if your NIC card's light is flashing? This flashing indicates network activity. Is your network card seated OK? If you go into "device manager" are there no problems with the card? Assuming that you pass this stage, now go on....

    ping your default gateway, in this case:

    ping 60.4.134.254

    if you DO NOT GET A REPLY then the problem is very likely your network cable.... Is it in correctly? Or perhaps its no longer working... This does happen, and should be something that you should check. It would do no harm to at least temporarily replace the network cable and try again.

    You should of course check that your IP settings are correct. If you are using DHCP then there is nothing to check, but if you have been asked to statically set the parameters then check that they are correct. An incorrect subnet mask, which is easy to type in with all of those 255.255 etc is easy. That would certainly cause those kinds of problems.

    Since I can't see your machine in person, you really have to write back and give me some more to go on. So try what I have posted here and let me know what happens....
  6. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    Thank you for your long response Phantasm, but all of those things are working correctly. I know my NIC is working fine because I am posting from that computer right now. The lights are flashing and everything SHOULD be working fine. But it's not...... :( I have tried repairing the network card as well. Like you said the only other thing I can think of is the TCP/IP or one of those things.

    Another thing I just thought about was that when I reformatted for some odd reason my ip changed. I have formatted before and the ip didn't change (It shouldn't because the mac address is unique and shouldn't change). I am not sure if this is a problem, or not.....

    That is all I can think of right now.
  7. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    Another thing that might have caused the problem is my roommate took out my 2nd NIC, which wasn't plugged into the network. But since then I have been having problems, once again this shouldn't be a problem, but just an extra little something.
  8. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    Another thing I just found out by talking to my roommate is that he can get on my computer, as well as everyone else in my house, but I can't get on anyone else's computer.

    This might help a little............
  9. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    can you access computers based on their IP address instead of their hostnames? try that and post back.

    so you CAN get workable network access (i.e. in this case the internet) through your NIC but you just can't use it to access the campus network?
  10. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    I can access a few computers but not all by using the ip. This still stinks because I don't know everyone's ip. But if this helps on changing something good :)
  11. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    So there ARE machines that you know the IP address of that you cannot access? Hmm....

    In any case, if you do this:

    nbtstat -R

    in a command prompt, does this make any difference?


    also, try running through some of the commands and stuff that are listed here:

    How to Reset Internet Protocol (TCP/IP) in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;q299357


    Also, try running some traceroutes on some machines you are unable to reach, i.e. :

    tracert hostname

    where hostname is the computer's name you can't reach, or

    tracert ip address

    where ip address is the computer's ip you can't reach.

    let me see some of the results if possible. to do so, you can pipe the results of the command into a text file, like this:

    tracert hostname > mytrace.txt

    then open mytrace.txt in notepad, copy and paste here.

    very likely this won't tell us much since its likely that there will be only 1 hob between you and the things you can't reach on the campus network but still it might tell me something.

    I take it no one else has reported similar problems?
     
  12. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    That is what i get when I did nbstat -R

    C:\Documents and Settings\XXXXXX>nbstat -R
    'nbstat' is not recognized as an internal or external command,
    operable program or batch file.


    This is what I get when I try to access my roommates computer. And gx1311 is his computer name.....

    C:\Documents and Settings\XXXXXX>tracert gx1311
    Unable to resolve target system name gx1311.

    This is what I get when I type in his IP.

    C:\Documents and Settings\XXXXXX>tracert XXX.XXX.XXX.XXX

    Tracing route to d-XXX.XXX.XXX.XXX.dynamic.umr.edu [XXX.XXX.XXX.XXX] over a maximum of 30 hops:

    1 <1 ms <1 ms <1 ms d- XX.XXX.XXX.XXX.dynamic.umr.edu [XXX.XXX.XXX.XXX]

    I hope these help you.....Because I am not sure what can be done. I am going to try and work through those M$ TCP/IP things and see...

    Trace complete.
  13. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    Hi,

    Its nbtstat not nbstat

    now, can you ping his IP address fine, but not his host name?? try that first, if so try the nbtstat -R command....
  14. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    Now I can't ping him either way....

    It times out the first time, then the second time it goes and the third time it goes, as well as the fourth.....I tried it again and 2 timed out and 2 made it......

    And I couldn't ping his comp name either...
  15. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    Well I took some time and played around with a few things today. I looked at my firewall and added everything that was of interest in ipconfig /all.

    Now they are all allowed by my firewall and for some odd reason I can now axs people's computers if I know their computer name.

    But one problem that I am having as well as others in the house is that we can't see all the computers connected to our local network. I can't my roommate can't and neither can a few other people. Is there any way I can fix this, or change something as far as hardware to get this to work???

    Anyway.....I don't know why adding in those certain addresses would make a difference, but it seems it did.....So part of the problem is solved.

    But the funny thing is that I have been using this firewall since I formatted and was able to browse their computers when it was running. Just a thought.........
  16. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    I thought I had the problem all ironed out, but it appears not. I have been using the internet fine and then all the sudden I lose it on my desktop and my nix box, but not my laptop (this one). I wonder if my NIC is going bad, or possibly a bad spot in my hub. I guess the good news is that I just ordered a new switch today and it should be here by Wednesday. Man this pisses me off. Oh well just one more thing for you guys to think about.


    Oh yeah....I also disabled my firewall and that wasn't the problem.
  17. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    actually from what you have said it really sounds now like you are dropping a lot of packets.... usually bad cable, bad NIC or bad hub. Try replacing them in that order.
  18. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    I have replaced the cable and that isn't the problem, so I am only to assume that it is the NIC or PCI slot. I know the hub works because I have switched sockets with a known good one. I'm going to switch PCI slots first, then change NIC's if I have to. I'll let you know how it goes.
  19. Mictlantecuhtli

    Mictlantecuhtli TechSpot Evangelist Posts: 4,916   +9

    It could also be a bad NIC driver. I had some connection problems in Win2k with its default drivers but Realtek's drivers worked fine (my card has RTL8139C chip).
  20. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    That's actually a good point and a bad driver would explain something like that.

    He actually said, I think (can't be bothered checking) that it just started out of the blue which would indicate that he didn't change the driver, however a file could become corrupt yeah.
  21. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    Well I uninstalled my drivers and tried to reinstall the ones off the website. But when I do it says that the .inf file is invalid. So I had to reinstall the XP drivers. Which I don't think are a problem, but......Everything seems to be working okay right now again. I'll keep you all posted.
  22. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Is your network TCP/IP or something like IPX? If it is TCP/IP your computer is probably assigned an IP through DHCP.

    I recently discovered a little bug (or what appears to be in my instance) in Windows XP. The "Repair" option is supposed to release and renew your adapter, but it doesn't seem to work correctly in all instances. Try typing in

    ipconfig /release
    ipconfig /release
    ipconfig /renew

    The key here is to type ipconfig /release TWICE. I'm not sure why, but it doesn't always work the first time (even though XP might beg to differ).

    You can also reset your TCP/IP protocol by typing

    netsh int ip reset C:\tcpreset.log
  23. poertner_1274

    poertner_1274 secroF laicepS topShceT Topic Starter Posts: 4,745

    Thanks Rick, I did that. But I am sorry to report that I still am unable to access the local network to see all the computers on it. Meaning that I can axs the internet fine, just not able to see all the computers on my network.
    There are others in my house that are having this problem as well. If i know their computer name I am able to access it, but listing all the computers on my network so I can just search them all is impossible to get working.
    I have gone to a known computer and even hit the UP button to get to the actual network, and it says it is unaccessable.
    And yes, it is TCP/IP.
  24. reverb

    reverb Newcomer, in training

    I am also having a problem with XP Pro & a TCP/IP network. I can access the internet fine but cannot browse the network. It is a DHCP network & I have noticed it picks up an IP address fine but an incorrect subnet mask which is why I cannot browse the network. Unfortunately I know the problem but not the solution!( other than setting a static IP address )
  25. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    You mentioned two NIC cards? that means you probably have two network connections. I've seen it where people would "bind" the connections together and once the other one is removed, it no longer functions on the network. Check your network and select your two network connections (if possible) and choose to unbind them.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.