TechSpot

Can't connect to wifi after formatting

By hitme
Feb 6, 2014
Post New Reply
  1. Hi everyone, I have a emachine D443 Laptop and I have just recently formatted and installed a new Windows 7 32 Bit Operating system. After installing the chip set driver and bios driver all other drivers I installed worked except for the wifi adapter, during installation of the wifi adapter an error saying "the device may not be present or could have been ejected/unplugged from the system". I have been searching for a solution ever since but have never found one. I even tried driverindetifier.com but witj no success. Help please. I can connect with LAN though.
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,371   +167

    List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, type msinfo32 in the box. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
    Generate and attach a DirectX report
    • For XP, click Start->Run, enter dxdiag
    • For Vista and later, click Start, enter dxdiag in the search box
    • DxDiag will open. Look at the buttons along the bottom of the DxDiag window
      ===> If 64 bit Windows, you’ll see a 64-bit DxDiag button. Click it to run 64-bit version of dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save as a text file to your Desktop
    • Click the Upload a File button to upload and attach the file to your next post
  3. hitme

    hitme TS Rookie Topic Starter

    Here is what I have under Problem Devices
    Network Controller PCI\VEN_14E4&DEV_4727&SUBSYS_051014E4&REV_01\4&28EC11EE&0&00A9 The drivers for this device are not installed.

    And here is the DxDiag File.

    Attached Files:

  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,371   +167

    Well, the good news is the adapter is there and being detected

    The WEIRD news.. dxdiag says you have an Acer??? But more importantly, the Network Controller in your problem report is a Broadcom adapter. That's why non-of the D443 wifi drivers will work. (none of them are for Broadcom)

    Before looking for a Broadcom driver for you, can you double check your model number? Does Acer make any sense?
    Code:
    ------------------
    System Information
    ------------------
    Time of this report: 2/7/2014, 10:58:42
           Machine name: PAVR-PC
       Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120330-1504)
               Language: English (Regional Setting: English)
    System Manufacturer: Acer
           System Model: ACRPRDCT
                   BIOS: InsydeH2O Version CCB.03.60.41V1.06
  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,371   +167

    Duhh... hang on.. is emachine Acer or Gateway?

    Give me the link to the support site you're using
  6. hitme

    hitme TS Rookie Topic Starter

    Yes the dxdiag says I have an ACER. If you are asking for the model number of my Laptop it says underneath it is emachine D443 series model number: ZQQ. It also says there that this is a product of Acer Inc.

    Here is the link to the support site https://support.gateway.com/us/en/emac/product/default.aspx?tab=1&modelId=3744
    Last edited by a moderator: Feb 6, 2014
  7. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,371   +167

    Hmm... seems very similar hardware to E443. Same makers for LAN, VGA, etc. Try the Broadcom wifi driver for the E443. Click HERE
  8. hitme

    hitme TS Rookie Topic Starter

    Thanks a lot. That worked. Thank you so much.

    Attached Files:

  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,371   +167

    Great news!! Glad to help :)
  10. Jerekin

    Jerekin TS Rookie

    Hey. that's also my problem but my system manufacturer is emachines not acer..
    can you help me?

    Here's my diag

    Attached Files:

    Last edited by a moderator: May 28, 2014
  11. Cobalt006

    Cobalt006 TS Maniac Posts: 1,814   +178

     
  12. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,371   +167

    Check your vendor site as Cobalt suggested for the correct drivers
    > Your Ethernet connection is Atheros
    > Your Wifi is Broadcomm


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.