Can't get system power back up now don't know what to do

By yuzuki
Aug 27, 2008
  1. hiya guys been sometime i have been here last time i was need help
    cos of storm took my system out.

    i did lot rma's get stuff fixed

    so few days ago i got my mobo back and my psu from rma

    i order new cpu go with it i got black edition amd x2 5400+

    at the time i did not know did not come with heatsink so i ordered

    Rosewill RCX-Z3 92mm heatsink

    i put stuff in and booted system up i check out bios settings

    all seem good no errors system started up fine

    i found out my hard drive gone bad it keep makeing sounds few times bios did not find it. it tryed loading os but it sit there trying load so i turn system off then i tryed turning it back on system would not boot up at all no fans would turn heatsink did not do any thing it was like it was dead haha.

    most of stuffon system is very new

    i know mobo geting power from light in case

    i know psu has watts power system 550w

    my friend tide sayed unhock connecters from drives and use one stick of ram see if it well boot i tryed that still did not start

    i was thinking it may be wire from power sw in the case to mobo but i do not know for sure. am out of ideas what to do
  2. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    What BRAND is the 550W power supply? It may have died, if it's badly built.
  3. yuzuki

    yuzuki TS Rookie Topic Starter

    psu is Thermaltake 550W ATX 12V 2.0
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...