TechSpot

Can't seem to set SSD as default boot device

By Kondora
Apr 30, 2013
Post New Reply
  1. Hi guys,

    So a quick background here. I went from using a normal HDD with windows 32 bit os and unplugged it while I installed 64 bit windows os on my new SSD (samsung 840), booted up no problem after setting the sata controller to AHCI and shut down to put my hdd back in as a storage drive, not yet wanting to format the drive just *incase* I have any issues with my ssd I can still use the pc via the hdd. Booted up fine however it was running in IDE

    So, I used the regedit suggested by windows of setting the value data box to 0 and it caused a bsod, I then read that I had to do the regedit for both the ssd and hdd so I did, which lead to no problems booting up and running AHCI just fine.

    However, the only way I can force my computer to boot using the ssd is to hit F12 for boot menu and select it, it is not an option inside my BIOS and by default, every time, it will just boot from my hdd unless it's not plugged in, in which case it'll boot the ssd. When it boots from hdd (as always if not using f12 menu) it'll show the ssd as drive E, effectively everything works ok but having to hit f12 every time I boot up or restart to select the boot device is going to get tedious :p

    Just to elaborate what I mean by it not being an option in the bios, I have the Gigabyte H55M-UD2H motherboard and the only boot devices that are displayed in the bios are Floppy, LS120, Hard Disk, CDROM, ZIP, USB-FDD, USB-ZIP, USB-CDROM, USB-HDD, Legacy Lan. With Hard Disk selected it'll behave as described above. To clarify, the only way I can appear to chose to boot from the ssd is via the boot menu (F12)

    Is there any way I can properly set it so the ssd is the primary boot device? Baring in mind I don't want to format the hdd at the moment
     
  2. JC713

    JC713 TS Evangelist Posts: 7,058   +919

    So you can only boot into the 32 bit version of Windows?
     
  3. Kondora

    Kondora TS Rookie Topic Starter

    No, selecting the ssd through the f12 menu means the ssd boots and that has 64 bit windows, works fine that way
     
  4. JC713

    JC713 TS Evangelist Posts: 7,058   +919

  5. JC713

    JC713 TS Evangelist Posts: 7,058   +919

    Wait, so you want to set it as the default boot drive?
     
  6. Kondora

    Kondora TS Rookie Topic Starter

    Erm, yeah? Wasn't that clear? ^^ If it properly boots from the ssd without me hitting f12 every time, problem solved
     
  7. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,475   +624

    You messed up. Set to AHCI, take out HDD, reinstall Win7. It's never good to swap IDE/SATA/AHCI operation post-install.

    Also, your mobo most likely does have the option to choose default drive. As you say, you only have HDD etc as boot devices, however there's another menu called 'hard drive priority'. Set the SSD to #1 and you're good to go.
     
    JC713 likes this.
  8. JC713

    JC713 TS Evangelist Posts: 7,058   +919

  9. JC713

    JC713 TS Evangelist Posts: 7,058   +919

    Wow, I don't know why I was so blocked from thinking of that lol. Today isnt my day :(. Herp derp *nerd*.
     
  10. Kondora

    Kondora TS Rookie Topic Starter

    Aaaand fixed, thanks guys! That was less painful than expected :) Not quite sure how for the past 4 hours of messing with it neither me nor my brother noticed the "Hard Drive Priority" option, him being used to a more up to date mobo/bios thus just chosing "SSD" or something similar as the first boot device which wasn't an option for me. I've now set it as you said, to have the SSD at the top of the priority list and all is good. That said, I shouldn't have to reinstall windows etc now? I do believe the reason for the regedits was kind of as a post-install workaround which I got from here; http://www.ithinkdiff.com/how-to-enable-ahci-in-windows-7-rc-after-installation/

    Thanks again
     
  11. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,475   +624

    Looks like you should be OK to have BIOS set to AHCI-mode, if you followed your linked guide.

    The options of 'default boot' and 'hard drive priority' have been on mobos from <2005 up to 2013's UEFI mobos from my experience. :)
     
     
  12. JC713

    JC713 TS Evangelist Posts: 7,058   +919

    2005 seems about right.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.