TechSpot

Can't use "s" when naming a file?

By zyglur
Jan 30, 2009
  1. Everything is in the title :
    I can't use the letter "s" when i want to name a file under the desktop.
    I can use "S" (capital letter), but not the "s".

    I've tried in the windows explorer and under other applications (wordpad, firefox...) and the keyboard is functionning perfectly, I only have that problem when I want to name a file on the desktop.

    I tried a reboot : no change.
    Just in case, I'm running malware and antivirus scans.
    Spybot found nothing.
    I will run my antivirus (ESET NOD32) and Malwarebytes.

    Any idea ?

    I'm Using Windows XP
    Sorry for my english (I'm french)
     
  2. JellyBrain

    JellyBrain TS Rookie Posts: 22

    very weird...
    So, you can type "s" but get an error when you want to create a file containing this letter? What kinf of error do you get?
    Can you create files containing "s" in other folders?
     
  3. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    I wasn't clear I believe.

    I can create any file, I don't get any error message.

    What happens is that when I am typing the name of a file nothing happens when I type the "s" letter.

    Example : I wish to create a folder on the desktop named "test"
    I use the right mouse button select Create New Folder...
    Then the folder is created and "New Folder" Underligned, I just now have to type the name I want. So I type on the keyboard [t] [e] [t] [Enter]
    I get a file named "tet" the "s" is missing.

    I tried typing several times the s to see if I had a faulty keyboard but nothing happens.
    But when I am under any other application (including under windows explorer) everything functions normally.

    I joined a picture (JPG file attached) of my desktop with a folder open to show you my problem.

    I created a folder and a txt file on the desktop and could not use "s" in the name
    I did the same under windows explorer without any problem.
     

    Attached Files:

  4. JellyBrain

    JellyBrain TS Rookie Posts: 22

    hm. sorry i have absolutely no idea what's going on, but would be curious if someone responds
     
  5. gguerra

    gguerra TS Enthusiast Posts: 559

    Try using the on screen keyboard to eliminate the possibility of it being you real keyboard. It is under accessories, accessibility, on screen keyboard (Windows XP) , dont know about vista
     
  6. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    Same proble with on screen keyboard

    I have scan the PC with Malwarebytes anti-Malware ; Spybot and my antivirus (ESET NOD32) and didn't find any virus or malware.

    I will now try a system restore.

    System restore didn't solve the problem maybe it older than my oldest restore point ?

    If anybody has an idea of how to solve my problem please tell me.

    Thank you
     
  7. mailpup

    mailpup TS Special Forces Posts: 8,462   +229

    Do you have another keyboard you can try to test with?
     
  8. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    I'm sure changing the keyboard is not the problem.

    1- I can use "s" anywhere but not on the Desktop
    2- The problem remains with the "on-screen keyboard"

    For example right now i'm using the same computer and the same keyboard and I can use the "s" as much as I want (ssssssssss) except on the Desktop

    I still have the problem.

    I haven't found any solution yet.

    If anyone can help me please.
     
  9. JellyBrain

    JellyBrain TS Rookie Posts: 22

    i'm still watching on this thread =))
     
  10. Spyder_1386

    Spyder_1386 TS Rookie Posts: 563

    Hey zyglur

    Seems pretty weird. I see there is another folder on your desktop called "Nouveau dossier" (based on the attachment you sent in). That does have an "s" in it. Was this folder created before the problem started happening? Also, in the folder called "tet but not TEST", you would agree that there is also an "S" .... only it's a capital S .... am I correct in saying this? Can you maybe tell us of when exactly the problem started happening? What were u doing before it started etc. Have you tried any other folder names other than the word "test" .... any other info concerning the problem might be helpful.

    Spyder_1386 :)
     
  11. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    Spyder you are right the capital S functions normally but not the small s.

    The folder named "Nouveau dossier" (it means "New folder") was created on the desktop the same day just to show that I have that problem only on the Desktop.

    I noticed the problem on the 30th or 31st of january. I didn't use the Computer regularly for a few weeks before and I had recover from a Vundo (+other malware) with the help of Bobbye a TechSpot member two weeks earlier. At that time the PC was completely clean but i don't know if i already had the problem or not. (link to techspot thread : http://www.techspot.com/vb/showthread.php?p=708723#post708723 )
    But I created many files on the desktop during the cleaning and I don't remember having that problem.

    Now that I look at the dates I realise that there may be a link between these two problems ( I thaught there was much more time between the two events)

    Please if anyone has an advice i still have the same problem.
     
     
  12. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Please disable any Desktop themes

    Do this:

    Right click on your Desktop
    Select Properties
    Select the drop down arrow and then select Windows Classic, select Apply

    Then select the Desktop Tab
    Select Customize Desktop button
    Select Web tab
    Select anything in the box, then select Delete button
    Apply
    Ok

    Then create a New Folder on your Desktop, and rename it to sss

    Did it work?

    Edit:

    Also zyglur, I have merged a number of your recent reply posts (about 10 of them)
    Now I realize that the last two had a reasonable delay involved, but because I noticed that you had done many replies to yourself I thought it best to do them all (note all previous post replies were done on the same day)
    If you feel a need to add any further info to your last post (if it is the last post still in the entire thread - ie it's not now) then please use Edit, and add to your post (just as I have done here :) )
     
  13. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    Thank you for your answer
    delay between the last two post was due to vacation and I also hoped someone would have answered before I came back.

    About your advice :

    No, it didn't work

    I selected the classic theme for windows and under the desktop/Customize/Web tab I found only a single line that I couldn't delete "Ma page d'acceuil" in French wich would be something like "My home page" in english). I still can't use s in folder names on the desktop.

    If you have any other idea ?

    PS : Sorry for the multiple answers I'll be more carefull now.
    Question : If i just edit the post, it won't be considered as a new one and someone that read it before won't see that new information was added to the thread unless he specifically checks if any editing was done, am I right ?
     
  14. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    I should have said "Uncheck" on that one

    1. Open Control Panel, double-click Display.
    2. Click the Desktop tab, and choose "Customize Desktop".
    3. Select the "Web" tab
    4. Delete all the items except "My current Home page"
    5. Uncheck "My current Home page"
    6. Click OK and close the dialog.


    Answer : You are right
    But I have personally checked this thread over two hours after it was posted by you
    Generally I have noticed that members tend to reply to themselves immediately, therefore the EDIT option is still valid

    Also there are others attached specifically to this thread, so even if I miss it (unlikely) others still have the chance to reply (sometimes even a day or more later)
    Generally I do check threads that I have posted on, especially when my post is not the last post in the thread. ie once this is fully resolved (inevitably) I will reply "Thanks for the update" Therefore if anyone replies I am immediately aware of this. I do also check for edits often, (again especially on threads I have supported or presently supporting on) and I am also notified by others at times, as well, if an Edit is made I eventually (within hours) know ;)
     
  15. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    "My Current Homepage" was already unchecked

    but... no change.

    So I came back to my usual Theme
     
  16. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Hmm I really thought that would work :(

    Anyway try this:

    Go to Device Manager (Start->Run-> Devmgmt.msc)
    Click on the plus sign (+) next to Keyboard
    Your keyboard will then be shown from this being expanded
    Right click on your keyboard and select Uninstall
    OK

    Then restart your computer
    Once Windows loads the newly found Keyboard hardware (automatically) again
    Test again your "s" key on the Desktop folders
     
  17. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    Terribly sorry for not answering faster but I spent most of my time at work lately and the problem is on my home PC.

    I uninstalled the keyboard as you adviced but nothing changed.

    :(
     
  18. jdillman1502

    jdillman1502 TS Enthusiast Posts: 232

    Just out of curiosity, in the registry, if you go to:

    HKLM, System, CurrentContolSet, Control, Keyboard layout.

    Do you have any values in the right windows, other than "(default)"?
     
  19. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    I'm not sure of what you are looking for :

    There are two folders "Keyboard layout" and "keyboard layouts"

    In keyboard layout there is no other key than the default but there are two other folders included.

    I post a picture for my explanations to be clearer.

    [​IMG]
     
  20. zyglur

    zyglur TS Rookie Topic Starter Posts: 22

    partially solved

    I never found a solution.

    But I have an interesting information.

    I reinstalled Windows using the same modified version I was previously using (Windows Xp Ultimate by Mad Dog) and after format and reinstall... the same problem was present (no "s" on the desktop). :confused:

    So I installed a normal version of Windows XP SP3 and everything is back to normal.

    My conclusion : The problem must be due to modifications included in Windows XP Ultimate
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.