TechSpot

CD-ROM wont go DMA

By The Shambler
Sep 24, 2003
  1. My CD-ROM doesn't seem to want to go into DMA mode. It's in PIO 4 and i tried changing it in windows but it wont change. I look in the BIOS and it says its in PIO 4 mode but there doesn't seem to be an option to change it. My motherboard is a Epox EP-8KTA3L+ and i'm running Windows XP. Does anyone know how i could possible fix this, it slows the whole system down when i use a CD and it runs really slow. It worked fine on my old computer so i don't think its the drive.
     
  2. Nic

    Nic TechSpot Paladin Posts: 1,928

    How old is the drive? What speed is it? Very old drives did not support DMA mode.
     
  3. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,745

    I would say if you can't get it in the way you have tried it is probably not supported as Nic has said.
     
  4. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Where did you look in BIOS?
    You should check both the IDE devices in standard settings and the IDE controller settings in integrated peripherals.

    And yes, if it is ancient, then it probably just doesn't support it.
     
  5. Rick

    Rick TechSpot Staff Posts: 6,305   +52 Staff Member

    There are many instances I've seen that have been driver related... Especially with older VIA chipsets.

    Try new drivers for your IDE:
    http://www.viaarena.com/?PageID=2
     
  6. The Shambler

    The Shambler TS Rookie Topic Starter

    Thanks Rick, those drivers worked a treat. I'm so happy :D . Now i can finnaly use the CD-ROM at full speed and without it hogging up the system. Whoopy!
     
  7. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,745

    Good to hear, glad you got it fixed.

    Hope to see you stick around and possibly help others. ;)
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.