TechSpot

CD-ROM won't load

By me(who else?)
Oct 10, 2004
  1. When I try to mount my CD-ROM drive, I get:
    mount: /dev/cdrom is not a valid block device

    I did some research, but no-one seems to have my same problem. Any sugeestions?
     
  2. MYOB

    MYOB TS Rookie Posts: 527

    You need to have it in /etc/fstab and have a valid mountpoint directory created
     
  3. Nodsu

    Nodsu TS Rookie Posts: 9,431

    How exactly are you mounting it? Do you actually have a CD in the drive?
     
  4. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    Yes, even with a valid mount-point and CD in the drive it won't load.

    I checked the linkage to the /dev/cdrom and it returned this:

    lrwxrwxrwx 1 root root 9 Oct 4 07:07 /dev/cdrom -> /dev/scd0

    My fstab says:

    /dev/cdrom /mnt/cdrom udf,iso9660
     
  5. Nodsu

    Nodsu TS Rookie Posts: 9,431

    /dev/scd0 is a SCSI CD-ROM.. Is this really the case?

    You can refer to a IDE CD as /dev/hdXX too.
    E.g. "mount /dev/hdc1 -t auto /mnt/cdrom"
     
  6. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    I don't know if it's SCSI, but it's a laptop drive(not very helpful, I know). On the fstab file, there is a /dev/cdrom1 and /dev/cdrom, despite the fact that my laptop only has one drive. One is linked to /dev/scd0 and the other is linked to /dev/hdc, but neither works
     
  7. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    You are only half right, strickly. You do need a mount point, but no entry in fstab is needed if you supply the device name and mount point, i.e.

    mount /dev/cdrom /mnt/cdrom

    however, if you want to say:

    mount /mnt/cdrom

    then you need the fstab entry.
     
  8. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    Try a manual mount, i.e.:

    mount /dev/cdrom /mnt/cdrom

    or

    mount /dev/cdrom1 /mnt/cdrom

    or even

    mount /dev/hdc /mnt/cdrom

    (where hdc is your CD-ROM)

    My /dev/cdrom is a symbolic link to /dev/hdc:

    0 lrwxrwxrwx 1 root root 8 May 19 22:50 cdrom -> /dev/hdc

    You might need to update the link for this to work.

    delete the link:
    rm /dev/cdrom

    recreate the link:
    ln -s /dev/hdc /dev/cdrom

    where hdc is your cdrom (i.e. secondary master)

    needless to say, you need to be root for this.
     
  9. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    I changed up my fstab a little bit, and I managed to get this:

    mount: /dev/cdrom is not a block device (maybe try `-o loop'?)

    But other than that, nothing. Unfortunately, I've tried everything here. Thanks for all the advice!
     
  10. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Where is your /dev/cdrom pointing to?

    I assume you have some RedHat..

    Look in /etc/sysonfig/hardware. Locate the entry that coresponds to your CD drive.

    It should be sth like:
    class: CDROM
    bus: IDE
    detached: 0
    device: hdc
    driver: ignore
    desc: "ATAPI CD-RW 52XMax"

    Note how it shows the /dev/ entry after "device:". Evidently my CD-ROM (CD-RW actually) is attached to /dev/hdc.

    This is a laptop. Keep in mind that Linux doesn't play well with those (we'll see how the new SuSE manages).

    All sorts of custom hot pluggable things don't work. For example if your CD-ROM in in a docking device then you have to boot up with the dock attached to make Linux find your drive.
     
  11. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,916   +9

    It is /dev/scd0 if you're using kernel 2.4.x or older. They use SCSI emulation for IDE burners. If the emulation layer is configured as a module, you need to load it first: modprobe ide-scsi.
     
     
  12. MYOB

    MYOB TS Rookie Posts: 527

    Correct. But don't forget I'm going off long supressed memories of when I actually used UNIX. BeOS doesn't have these problems...

    That said, I miss my Indy working...
     
  13. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    Modprobe returns a command not found when I use it? I did install the 2.6 kernel, but I still boot to the 2.4 (at least until I get networking working). I get the same error under both kernels (block device, that is).
     
  14. Nodsu

    Nodsu TS Rookie Posts: 9,431

    You have tobe root to use modprobe. In case you haven't put /sbin and /usr/sbin in the root's PATH variable then you have to type it manually e.g. /sbin/modprobe blabla.
     
  15. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    I tried modprobing, but I still have the problem. There must be something wierd going on...
     
  16. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,916   +9

    insmod should work in 2.4 kernels too.
     
  17. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Did you look in /ets/syconfig/hardware? You will see if Linux has found your CD-ROM at all and where it thinks it is.
     
  18. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    I tired to use that location, but hardware doesn't exist puke:

    SOmebody must have had this problem. Oh well, I 'll keep trying :knock:
     
  19. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    Finally, I found a fix! Stupid me, I deleted /dev/hdc and made it a symlink to /dev/scd0 :monkey: . I remade the hdc file with MAKEDEV, but now I still can't eject or mount:

    Mount says:
    wrong fs type, bad option, bad superblock on /dev/cdrom,
    or too many mounted file systems
    (could this be the IDE device where you in fact use
    ide-scsi so that sr0 or sda or so is needed?)

    Eject says:
    eject: unable to eject, last error: Invalid argument

    FStab:
    /dev/cdrom /mnt/cdrom iso9660 ro,noauto,user,exec 0 0


    I do have hdc=ide-scsi in my grub config...Anybody?

    P.S. I think this is why I deleted hdc in the first place...
     
  20. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,916   +9

    Depending on your kernel, I don't think you'd need that. 2.4 kernels might work without, 2.6 definitely does. You can mount CDs/DVDs "simply" by mount -t iso9660 /dev/hdc /mnt/cdrom.
     
  21. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    I tried to mount -t iso9660 /dev/hdc /mnt/cdrom, but it still didn't work (same error). I don't know what else to try... :blackeye:
     
  22. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Do you actually have a data CD in the drive? :p
     
  23. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    I just bought UT2004, and this is really bugging me (BUMP).

    My eject function doesn't even work! It returns:

    eject: unable to eject, last error: Invalid argument

    It seems like a problem with the kernel. Then again, the 2.6 kernel returns the same thing.

    PLEASE HELP! I'm begging you! :angel:
     
  24. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,916   +9

    I'm beginning to think the CD drive isn't secondary master, or you don't have proper kernel modules loaded.

    In command line, go to /proc/ide, and type

    grep -ir "cdrom" *

    That will search for string "cdrom" from files in directories there.

    If the drive indeed is secondary master, one line should say

    hdc/media:cdrom

    If it's something else than hdc (like hdb), use that instead when mounting.

    If it returns nothing, then the drive wasn't detected at all. In that case, type

    lspci | grep IDE

    The first part, lspci, lists all PCI devices (cards and onboard). The second filters only those that have IDE in them.

    The result should display the computer's IDE controllers.
     
  25. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    It does indeed say that /dev/hdc is my CD-RW drive. As for kernel modules, I just looked around a bit... the grub.conf says hdc=ide-scsi, TWICE! First, it's listed as a kernel option, then in Append. I don't know if this is the problem, I deleted one instance and it still returns the same problem. I'll try without any ide-scsi and see if it works... :giddy:
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.