TechSpot

CD-ROM won't load

By me(who else?)
Oct 10, 2004
Topic Status:
Not open for further replies.
  1. me(who else?)

    me(who else?) TS Rookie Topic Starter Posts: 433

    Update: I erased the entry from /etc/fstab and Redhat put back all the files, but it linked scd0 to the cdrom drive. This means *something*, but I don't know what.

    Yes, when I try to mount under this new config it returns no valid block device, and yes there is a disk in the drive. :suspiciou
     
  2. KBerger

    KBerger TS Rookie Posts: 17

    Perhaps, it's a bit late and nothing really new. But I would look what dmesg thinks your cdrom is. It must say "hdc: ...(then goes the brand of your cdrom)". I mean, if it says your cdrom is "hdd", then it's even so. It would mean your (ide!)cdrom is linked with the node /dev/hdc(hdd).
    About ide-scsi option(scsi emulation): it's only here for CD-burning on ide cd-burners, and not for accessing data CDs on IDE cd-drives. The corresponding SCSI dev node will be used for burning. So, the /dev/cdrom must be a link to your /dev/hdc. It must be mounted on whatever mount point you choose(like the way you did it).If it doesn't, and the disk is there, it could be: bad disk or/and broken drive. Or, a bug in the "mount" utility? Not likely as thousands use it without running into such problems.
    If the dmesg command output says (your brand name)CDROM is here as "hdc", then it can recognize the device as ide cdrom drive. It must mount,then, unless for the reasons mentioned above.
    Another thing one would check is this master/slave jumpers on the drive itself, but yours I assume to be a laptop.Don't think you must check the jumpers.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.