TechSpot

Cisco router 2611 Need Help with Setup

By nzemke
Apr 22, 2009
  1. This is my first post so please understand reading this that I have no formal cisco training and everything I know is from what I have read online.

    So heres the situation:
    I am unable to navigate to any of the websites i am hosting on my servers, externally or internally. I am trying to get the winbox to work with the websites first before I go and add the ones going to the nix box. When i run a ping from inside the network the domain names return the proper internal address. when i try to ping the site externally i get a "could not find host" message. Any help would be greatly appreciated!

    Equipment:
    Cisco 2611 router
    Windows Server 2003: DNS/DHCP/IIS
    Ubuntu Server: Apache
    Anticipated end result:
    I intend to run websites from win box and the linux box. My friend has all of his php stuff running on the Nix box and I have the ASP pages running on the win box. Each server will host multiple sites.

    Current setup:
    Currently the DNS server is setup with all of the A records set to the appropriate internal IP

    Server 1 WinBox has a static IP of 192.168.1.10
    Server 2 NixBox has a static IP of 192.168.1.11

    On the IIS server the Host Header value has been set to the domainname . com and www . domainname . com for each site.

    Cisco Router 2611 running-config:
    **I have edited the IP address to protect the integrity of the servers**

    Current configuration : 1178 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    ******************************
    !
    hostname Router
    !
    !
    no ip subnet-zero
    !
    !
    ip domain-list MyDomain1.com
    ip domain-list MyDomain2.info
    ip domain-list MyDomain2.net
    ip domain-name MyDomain1.com
    ip host ServerName.MyDomain1.com 192.168.1.10
    ip name-server 192.168.1.10
    !
    ip audit notify log
    ip audit po max-events 100
    !
    !
    !
    interface Ethernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    full-duplex
    !
    interface Ethernet0/1
    ip address (external IP) 255.255.255.0
    ip nat outside
    full-duplex
    !
    ip default-gateway (outside Gateway IP)
    ip nat inside source list 1 interface Ethernet0/1 overload
    ip nat inside source list 101 interface Ethernet0/1 overload
    ip nat inside source static tcp 192.168.1.11 22 (external IP) 22 extendable
    ip nat outside source list 101 interface Ethernet0/0
    ip classless
    ip route 0.0.0.0 0.0.0.0 Ethernet0/1
    no ip http server
    !
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 101 permit tcp any any
    access-list 101 permit udp any any
    access-list 101 permit icmp any any
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    end
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.