Command and Conquer first decade on vista not responding

By Lightingbird
Apr 12, 2009
  1. I need help.

    Huge CnC fan here so I went out looking to play it again. I got the first decade game that has the first game all the way up to Generals Zero. I was planning on trying to the run the CnC All stars mod but no matter what I do it keeps freezing up. So I uninstalled the all stars mod and tried again. The launcher comes up but when I pick a game it freezes up and I have to go into the task manager and kill the program. Here is what I have tried.

    1. I went and downloaded the 1.2 patch for the game and tried to run it. Still freezes up.
    2. Tried to run the game as admin on each actual game.exe and the launcher. Game still freezes up.
    3. I went to each game.exe including the launcher and changed the compatibility to windows xp. Game still freezes up.
    4. Disabled my firewall and game still freezes up.


    I run Vista 32 on a dual core with 4gb's of ram. I've ran games that have much higher graphic demands than this.

    Any ideas before I give up? Well any ideas besides reinstalling XP.
  2. Lightingbird

    Lightingbird TS Rookie Topic Starter Posts: 44

    Its about to drive me nuts!
  3. rev_olie

    rev_olie TS Maniac Posts: 560

    I had this problem and its a real pain because of Vista but there is a solution.

    Its because of the "Run as administrator" option required.
    What you need to do is go into the Command and Conquer folder in C: or where ever installed and you need to find each individual .exe file. For example if you want to run C+C Yuri's Revenge then go into the Yuri's revenge folder and find the application ( I think its called YURI.exe) then right click it and run as administrator.

    However sometimes it still freezes here. If it does open the CD tray and then close it again. Wait for the Auto run screen for First decade and without closing it then select which game you want to run and then again right click and run as admin.
    Currently i have all of the games as shortcuts on my desktop without the need for the auto run menu as it seem to be the only real way with windows Vista.

    Hope it works :D
  4. Lightingbird

    Lightingbird TS Rookie Topic Starter Posts: 44

    Ive already tried that but thanks.
  5. rev_olie

    rev_olie TS Maniac Posts: 560

    Sorry just reading again, i missed that on your list :blush:

    Did it work before you installed the mod?

    Obviously the first step if it did would be to reinstall the whole game but if not then make sure you have patched up. Also in trying to figure it out, right click the icon again and change compatibility to windows 98. I know it seems low but it crashes on mine on Vista with XP compatibility but 98 usually works. Worth a try ;)

    Also researching noticed you posted this on over 5 different forums so i can see your desperate :D
  6. Lightingbird

    Lightingbird TS Rookie Topic Starter Posts: 44

    Haha yea I am... I got it to work. I just had to run as admin and crack it up on the cpu usage in task manager. Ha I am the admin not sure why I have to run that command but oh well!
  7. rev_olie

    rev_olie TS Maniac Posts: 560

    Yeah it seems to be one of those totally pointless things that appeared for some reason but hey ho glad it works.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...