TechSpot

Comp will not start up, please help

By samjohnson
Jun 20, 2007
  1. I just built a computer for the very first time. I just now got everything put into it and hooked up. The problem is that when I hit the power button it will go on for about 2 or 3 seconds then just quite. If anyone knows what could be the problem please let me now.
     
  2. samjohnson

    samjohnson TS Rookie Topic Starter Posts: 320

    Ok well I figured it out by myself. The PSU was dead. Before I knew I decided to switch the PSU from the one I bought to the one that came with the case, and wouldn't you now it the one with the case is the one that works. :p
     
  3. gavinseabrook

    gavinseabrook TS Rookie Posts: 528

    Not a dead cpu, maybe just not as powerful.
     
  4. samjohnson

    samjohnson TS Rookie Topic Starter Posts: 320

    No the power supply is definetly dead. The one that came with the case is only a 450 watt the one I bought was a 500 watt. Thanks anyway.
     
  5. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    PSUs are the heart of computers. Why people choose to skimp and get el cheapo PSUs really is a wonder. Failing PSUs can cause all sorts of mysterious errors.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.