Comp Wont Turn ON is it the PSU or the Mobo

By TeMOR
Mar 3, 2008
Topic Status:
Not open for further replies.
  1. Well my computer doesn't turn on anymore. It was working fine and then the power cord of the surge got unplugged from the outlet. Needless to say the comp wont turn on anymore. I was wondering if its the psu or the mobo that has messed up. When I plug in the comp the steady power light turns on, on the mobo which i assume it means it receiving some type of power. But when I press the power button the led lights of comp flash on and then turn back off. So does anybody know if its the psu or the mobo that is damaged?
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Probably Power Supply (hard to say really)

    Just for a quick option:

    Remove the power cord
    Hold the On button in for 30 secs (releasing all internal voltage)
    Put the power cord back in (securely)
    Turn on (I hope)
  3. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    read the "NO POST" guide in the guides forum.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  5. TeMOR

    TeMOR Newcomer, in training Topic Starter Posts: 18

    well i got another psu from another computer and connected it to the comp ... same thing the fan n leds turned on n moved for about half a sec n then died. So is it safe to assume now that its the mobo that is shot?
  6. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.