TechSpot

compaq Armada 7730MT wont accept Hard drive

By uzorp
May 28, 2007
  1. my old Compaq armada 7730mt notebook wont accept any HDD it was working well with win200Sp3 on it till my friend borrowed it he came back some few days later,but the laptop won't bootup, it would startup and say enter command path e.g C:/COMMAND.COM.
    I tried to format it having using a WIN98 startup floppy,but at 100% the formats stops and "unable to create boot sector" massage shows up, i changed the HDD but still gets the same problem.
    I'm in a fix now,any one with a solution please help
    Thanks Phill.
     
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251

    Hi

    Look in the BIOS for any kind of virus protection, if its turned on it prevents anything from writing to the boot sector of any hard drive installed.

    Regards
     
  3. uzorp

    uzorp TS Rookie Topic Starter

    hi,
    thanks but i cant get to the bios,compaq says the bios was on the 1st installed HDD,so i guess i lost that when the first HDD crashed and i put the one that is having this problem now,please any other solution?
     
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251

    Hi

    Go here, its listed as
    DESCRIPTION: Creates a ROMpaq diskette to upgrade the System ROM.

    Might be what you need

    Regards
     
  5. uzorp

    uzorp TS Rookie Topic Starter

    thanks, i tried that,the upgrade was successful but the problem still persist,any other solution?
    regards
     
  6. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    you cannot "borrow" a bootable hard drive from one system or motherboard and use it on another. Windows configures itself for each system and motherboard by serial number.
     
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,915   +167

    The bios is not located on the hard drive. It is located in a chip on the motherboard. Are you sure you are pressing the right key on bootup? F2? F10?

    Of course Tedster you can't place a hard drive with an OS installed in another computer and expect it to boot, but he has said that he has also tried a freshly formatted drive with the same "no go" results
     
  8. uzorp

    uzorp TS Rookie Topic Starter

    thanks all,
    i'm still stuck with the problem though,when i try to format the HDD on the laptop,the format starts, when it gets to 100% i get "FORMAT COMPLATE:CANNNOT CREATE BOOT SECTOR" and it stops there.some one suggested the HDD controller is bad,i'm trying to get another board to see if it will work,the HDD id controller is on the mainboard.
     
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 20,915   +167

    It is rare that the hard drive controllers in both desktops and laptops go bad, but it does happen. I am more concerned that you can't access the bios. This could be caused by a bad CMOS battery or a bad motherboard also
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.