TechSpot

Computer switched off!!

By Deeloughran05
May 10, 2005
  1. My computer just switched off, and i have restarted it but it will not come on, the monitor is on, and so is the mouse and keyboard (light on) and power supply (light on), do you know what might have happened, might it have blown?
     
  2. isatippy

    isatippy TS Rookie Posts: 497

    a little info wouldn't hurt like was it getting hot and is the mother board light on if there is one it would be on the main board in your computer.
     
  3. Deeloughran05

    Deeloughran05 TS Rookie Topic Starter Posts: 24

    Yeh the computer was very hot, it was left on a few hours due to downloading, i don't think my motherboard has a light :S...i opened the case up and there didn't seem to be anything visibly the matter with it, is there anything i could try?
     
  4. teztina

    teztina TS Rookie Posts: 23

    do you have a good cooling system...u might have over heated the processor...
     
  5. isatippy

    isatippy TS Rookie Posts: 497

    I wouldn't think it would have gotten to hot and fried because it would have happened before. You might try replacing the power supply.
     
  6. zephead

    zephead TechSpot Paladin Posts: 1,569

    the power supply is a major suspect, but what type of processor and motherboard are you using?
     
  7. Deeloughran05

    Deeloughran05 TS Rookie Topic Starter Posts: 24

    Processor:
    Intel Pentium 4 3.2GHz
    Motherboard:
    ASRock P4S55FX2

    Ive had the computer around 6 months and this hasn't happened before, and it was only on a few hours. The power supply unit button lights green though when i turn the hard drive on (though the harddrive won't turn on)
     
  8. isatippy

    isatippy TS Rookie Posts: 497

    I still say the psu might be the problem. You wouldn't won't to replace the process $200 usd or more. Also the m/b isn't the best brand so that could the problem too.
     
  9. Deeloughran05

    Deeloughran05 TS Rookie Topic Starter Posts: 24

    I replaced the power supply with one from another computer, but didn't work :hotbounce the ac adpater at the back has its green light on, and the wireless keyboard n mouse, (powered from the hard drive) all are lit up, so the hard drive must be recieveing power.
     
  10. isatippy

    isatippy TS Rookie Posts: 497

    I might say the m/b then but I'm not sure. you might take it to a computer shop and have them look at it.
     
  11. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    Another possibility is that your BIOS turned the CPU off if it overheated. Many newer boards have thermal protection circuits.
     
  12. isatippy

    isatippy TS Rookie Posts: 497

    it's a 6 month old m/b he said.
     
  13. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    Age has nothing to do with overheating protection circuits. If it's hot, they'll shut if off no matter how old it is. It's designed to protect your motherboard. If that is indeed the case it's doing its job. (They're like a circuit breaker.) ;)
     
  14. Deeloughran05

    Deeloughran05 TS Rookie Topic Starter Posts: 24

    Well i packed it up, and sending it off tomorrow, back to the suppliers where i'll have to wait up to 30 days to see whats the matter wif it :suspiciou
     
  15. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    I'm sorry to hear that, best of luck, and hopefully you get it back quickly.
     
  16. zephead

    zephead TechSpot Paladin Posts: 1,569

    asrock makes a pretty shoddy product. i wouldn't be surprised if the board was the culprit.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...