Computer won't start, help please

By csba09
Nov 23, 2009
  1. Hello,

    I'm new to these forums. The other day I went to turn on my computer, I pressed the power button and absolutely nothing happened. I did a google search to see if I could find out what was wrong. I've tested my power supply manually with a multimeter and everything seems to be working fine with the PSU.

    I have also tried to manually power on my computer using the screwdriver technique on the "pwr on" pins, but it didn't work.

    Is this a motherboard problem? Is there anything else I should try?

    Thanks for any help you can give me.

    System Specs:
    AMD Athlon 64 x2 4200
    Asus a8n-sli motherboard
    Hiper 580W psu
    2gb corsair ram
    evga nVidia 7600 GT
    Windows xp
  2. BorisandBailey

    BorisandBailey TS Enthusiast Posts: 154

    I know this is weird, but how about the power strip? I was fixing a new computer, hooked it up to a new power strip, and it wouldn't turn on. Turned out the power strip was bad. Sometimes, the answer to these things lies outside of the computer. Another thought: the ATX four-pin connector from the power supply to the circuit board is loose.
  3. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  4. csba09

    csba09 TS Rookie Topic Starter

    I tried plugging it directly into the wall and didn't have any success. I've also tried repositioning all the connectors and still nothing.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...