TechSpot

Computer won't start on a new build

By beerabuser30
Nov 12, 2011
Post New Reply
  1. beerabuser30

    beerabuser30 TS Enthusiast Topic Starter Posts: 294

    He switched to a known working psu and it did the exact same thing.
     
  2. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 6,091   +1,519

    Double check the front panel connectors on the motherboard with the manual specifications.

    Check all cable connections including memory modules for proper seating. If you have different memory, you might want to try swapping the modules.
     
  3. beerabuser30

    beerabuser30 TS Enthusiast Topic Starter Posts: 294

    So the reason it wouldn't turn on is he didn't have the standoffs in. I didn't even think to ask him about those I just assumed. It now turns on, it wouldn't boot, switched ram everything works. On a side note he then tipped his old computer on his knee, gashed it, has to go to the hospital. IT can be dangerous.
     
  4. beerabuser30

    beerabuser30 TS Enthusiast Topic Starter Posts: 294

    Update, he decided against going to the hospital. He turns it on and gets disk boot failure. He has both drives connected. He has the windows disk in but gets this failure anyway. I had him switch the ports, the cd drive is spinning. Ideas?
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.