TechSpot

Computer wont start

By glaze007
Mar 31, 2010
  1. Computer comes on but not monitor

    I have a Dell XPS600 geforce 7900gtx sb xifi left computer on lastnight went to bed, got up this morning computer was off. Bit power button to come on the button just clicks starts to come on then goes off. After clicking button a while it finally comes on. Fans power up cd drvies power up sounds like everything is running but the screen will not come on, it stays black. I have taken out video card an sound card cleaned an reseated. Checked all cables inside all is pluged an seated properly.
    So the short of it is computer shutoff itself an now when comes on monitor will not power up but fans an drvies do.

    any suggestion with this would be appreciated, since im starting to thing my mobo as died.
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Try replacing the power supply
     
  3. license27kill

    license27kill TS Member Posts: 70

    if your mobo died, no powers would be distributed on your fans..
    if your psu died, no powers either

    it boils down to your graphics card or somewhere in between..

    or better yet.. if you have working spare parts, you might kindly try it on..

    ;)
     
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "if your mobo died, no powers would be distributed on your fans"...

    Not true license27kill, the fans could still run...

    "if your psu died, no powers either"...

    Not true either. Bad power supplies can drop just one voltage and still power LEDs or fans, but not allow a computer to boot
     
  5. license27kill

    license27kill TS Member Posts: 70

    umm. but on my experience..
    my fuse blowned up..
    so can't distribute power anymore..

    i think i just had generalized on my explanations..
    don't worry.. ill make up to it..

    thanks ;)
     
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Many cheaper power supplies will burn up and fail with out blowing a fuse
     
  7. license27kill

    license27kill TS Member Posts: 70

    oh.. and you still use the crap.. haha.. lol..

    time for replacement..

    anyway , topic is getting "off- topic" i hope his problem is solved by now
     
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Your understanding of Electronics is a bit weak I'm afraid ;)
     
  9. license27kill

    license27kill TS Member Posts: 70

    i agree..! :)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...