Connected to network, but no Internet access - can't access network properties

By succip
Jul 14, 2010
Topic Status:
Not open for further replies.
  1. Hello,

    I know this is a long shot. I'm staying in what's basically a hotel for the next couple months. I was on their free wireless networks up until a couple of days ago, when it just cut off my internet access all of a sudden.

    They have confirmed it's nothing on their end. My roommates have had steady access on their computers no problem, my iPhone as well.

    I obviously have no access to their modem, to make issues more difficult, when I right-click any of the network connections, a dialog box will appear, but all the menu options are blank. I can't do anything to the connections except rename them. Anything else yields a message box with no message.

    if there's any other way to access the TCP/IP properties that would be great. Right-clicking the connection and clicking properties is the only way I know of.

    I have tried winsock repair, uninstalling/reinstalling wireless driver, and just about everything else I could think of.

    ipconfig /all gives me the following output:

    Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Users\Owner>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Owner-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Mixed
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : bc.hsia.telus.net

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . : bc.hsia.telus.net
    Description . . . . . . . . . . . : Atheros AR9281 Wireless Network Adapter
    Physical Address. . . . . . . . . : 00-21-63-49-21-BB
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::10ee:9274:8bcd:7470%41(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.113(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : July-13-10 10:43:18 PM
    Lease Expires . . . . . . . . . . : July-14-10 10:43:18 PM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 75.154.133.68
    75.154.133.100
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection* 16:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Anchorfree HSS Adapter
    Physical Address. . . . . . . . . : 00-FF-20-99-40-9A
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection* 12:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : TAP VPN Adapter
    Physical Address. . . . . . . . . : 00-FF-E2-34-9B-A1
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek RTL8102E Family PCI-E Fast Ethern
    et NIC (NDIS 6.0)
    Physical Address. . . . . . . . . : 00-1E-33-5B-09-EB
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 6:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.cgocable.net
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 7:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.McMaster.CA
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 11:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.{7EB9EB20-198D-49C5-8B23-CDD355559
    B54}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 13:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.no-domain-set.bellcanada
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 21:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.{335941FE-CEA8-44DD-B5CE-8CA12608C
    D5E}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 14:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.{E2349BA1-2D9E-4C4A-AD97-B81510823
    E1F}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 22:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 02-00-54-55-4E-01
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2822:c18b:2ecb:6b7c(Pref
    erred)
    Link-local IPv6 Address . . . . . : fe80::2822:c18b:2ecb:6b7c%21(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Local Area Connection* 26:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.{E2349BA1-2D9E-4C4A-AD97-B81510823
    E1F}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 27:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.{E2175C84-BDEB-4258-B3E6-37312B700
    449}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 30:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : isatap.{2099409A-D612-4BE7-8CAA-21C8F246A
    2A9}
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 31:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : bc.hsia.telus.net
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #10
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 35:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 6TO4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 36:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 6TO4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 37:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 6TO4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 38:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 6TO4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 39:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 6TO4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 25:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 6TO4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 40:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 6TO4 Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    C:\Users\Owner>


    Any help is greatly appreciated; I plan on being here a while.
    Thanks!
  2. jobeard

    jobeard TS Ambassador Posts: 13,348   +300

    Appears you are on Vista ( Microsoft Windows [Version 6.0.6001] )

    and running from an Admin Login (ie Owner and other than maintenance, you should be using a Limited Account, eg: UAC but solve that latter)

    Disconnect from the router
    Goto Control Panel > Network and Internet > Network Connections.
    Right click on ‘Local Area Connection’ & click ‘properties’ option.

    scroll and find the Internet Protocol V6
    clear the [x] preceeding that line
    click ok

    get a command prompt (run->cmd) and enter
    netsh int ip reset
    netsh interface ip delete arpcache
    ipconfig /flushdns
  3. succip

    succip Newcomer, in training Topic Starter

    Thanks for your help.

    Unfortunately, I can't access the network properties through the way you described. The right-click box is completely empty. I took a screenshot and hosted it on photobucket, but I can't post a link here because I don't have a high enough post count. When I right-click the Local Area Connection, all of hte options are completely blank, and selecting them just gives me a blank messagebox.

    Additionally, when I run the commands I get:

    Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Users\Owner>netsh int ip reset
    The following helper DLL cannot be loaded: IFMON.DLL.
    The following command was not found: int ip reset.

    C:\Users\Owner>netsh interface ip delete arpcache
    The following helper DLL cannot be loaded: IFMON.DLL.
    The following command was not found: interface ip delete arpcache.

    C:\Users\Owner>ipconfig /flushdns
    The requested operation requires elevation.

    C:\Users\Owner>

    I figure IFMON.dll is corrupt or something, so I downloaded another one. I'm not sure where to put it though.

    Anyway anymore tips you can give me is greatly appreciated!
  4. jobeard

    jobeard TS Ambassador Posts: 13,348   +300

    hmm; I've seen that ELEVATION comment before; turn of UAC and try again please
  5. tipstir

    tipstir TS Ambassador Posts: 4,607   +80

    Network adapter is bad or the driver is corrupt. Is this onboard NIC on desktop, laptop or netbook? You said you un-installed and re-installed the driver and it's still not working?

    On-board Mini PCI-NIC
    PCI-E NIC
    PCI-NIC
    USB2.0 Dongle
    PC-Card Bus 32-bit

    Which one? Do you have another one you can try out?

    Any firewall software running with Windows Firewall?
  6. succip

    succip Newcomer, in training Topic Starter

    I disabled UAC, and then that last command worked, the /flushdns. But the first two still didn't work, saying IFMON.dll cannot be found.



    My device manager says:

    Realtek RTL8102E Family PCI-E Fast Ethernet NIC (NDIS 6.0)


    It's a Toshiba Notebook Satellite L300. Should I reinstall the driver for that one too?
  7. tipstir

    tipstir TS Ambassador Posts: 4,607   +80

    Are you the only user of this laptop? Do you have admin rights? You should have the admin right so you can change the default settings. Yes the driver has to go. Go to the Realtek site or pull the driver off MS instead.

    This is what I would do.

    1. download the driver from Realtek for RTL8102E for your version of OS
    2. download IOBIT Advance System Care free (found here on this site)
    3. install/run Advance System Care press the (care button)
    4. uinstall the driver for RTL8102E
    5. reboot the system
    6. run advance system care again press the (care button)

    Now quick question for you does the laptop have wireless feature? Does that work? If it does can you enable it?

    7. Now go into the Device Manager right click on scan for new hardware detection. This might have ran when you first rebooted. If not let the driver come off the internet to install on your system.

    8. If you don't have wireless adapter, use the downloaded driver to install the driver.
  8. jobeard

    jobeard TS Ambassador Posts: 13,348   +300

    IFMON.dll 'should be' located at \windows\system32\

    and sometimes there's a copy at \windows\driver cache\
    or \windows\I386\

    I loaded I386 from the CD to C:\I386

    any rate: search fo IFMON (notice the missing .DLL)
    if you find IFMON.dl_ then you can use EXPAND to place it back into system32

    eg: you find \windows\l386\IFMON.DL_
    get a command prompt and cd to \windows\i386 and then
    expand IFMON.DL_ \windows\system32\IFMON.DLL
  9. succip

    succip Newcomer, in training Topic Starter

    Sorry for the late reply, obviously I have limited access to internet.

    Thanks all for your help, but none of your suggestions worked.


    I'm not sure what you mean jobeard by using "expand" and putting it back. I've tried just dragging and dropping the new IFMON.dll I found online into the windows\system32\IFMON.dll and windows says I need permission to do this.

    I hate windows.

    If I have any other options, lemme know!

    Thanks again!
  10. jobeard

    jobeard TS Ambassador Posts: 13,348   +300

    the Expand tool performs a decompression.
    Files like xxx.DL_ are compressed and the real file needs to reside in windows\system32
    as xxx.dll

    Expand will need to run as admin, so disable UAC, perform the action and then reenable UAC
  11. tipstir

    tipstir TS Ambassador Posts: 4,607   +80

    If the suggestion doesn't work? Better to re-install the OS again. Good luck!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.