Connection has dropped considerably in speed

By DisplayError
Dec 22, 2008
  1. My connection used to be of this speed:
    As of today, it has dropped down to this:
    I've tried resetting the modem/router (it's a two in one), but it was of to no avail. The modem/router is shared with my cousin. After resetting the modem, I went to a site to download a dummy file; the speeds seen above (second picture) were the speeds that I had observed. The same speeds were observed on my cousin's computer as well.
  2. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    As a first step, try checking with the router manufacturer to see if there are any firmware updates for the device. If there are any, please apply them to the device and see if that resolves the problem.
  3. jobeard

    jobeard TS Ambassador Posts: 9,153   +598

    change the WiFi channel and if you have b/g or g/n modes, force G-Only
  4. DisplayError

    DisplayError TS Rookie Topic Starter

    I have yet to test this out, as I do not have access to the modem (at the moment), but I called up my ISP and I've been told to remove all the wires from the modem/router and from the wall jack(s).

    I have done what the operator had said, and it too did not help. I then called again, and I was advised to call up me computer manufacturer and report the problem so that the manufacturer could troubleshoot the problem.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...