TechSpot

Connects to Ethernet but not Wi-Fi

By Linda.
Nov 17, 2012
Post New Reply
  1. Hi! It's my first post on this forum, and I'm not sure if this is the proper place for this thread, but hey :]
    I have a Dell Inspiron, and am totally clueless about tech. As of now, my computer connects fine using an ethernet cable, but it doesn't connect via wifi.
    When I do attempt to connect via wifi, it appears as connected but I cannot connect to a website.
    Any ideas? >_<
    Thank you all so much!
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,516   +336

    Is this a new system and/or has wifi ever worked on this system?

    what version of windows {xp, vista, win/7, win/8}

    the make and model of your router?

    On {xp, vista} run -> enter CMD and enter key; on Win/7 search -> enter CMD and enter key

    In the new command prompt window that results, enter IPCONFIG /ALL >myTCP.txt and enter key

    Now when you come back with a follow-up, COPY/PASTE the content of the myTCP.txt into your post
     
  3. Linda.

    Linda. TS Rookie Topic Starter

    Is this a new system and/or has wifi ever worked on this system?
    Wifi has not worked on this laptop for about 3 months now; I was too lazy to try to fix it. However, wifi had been working from when I first got this laptop about 2 years ago until 3 months ago.

    what version of windows {xp, vista, win/7, win/8}
    Windows 7!

    the make and model of your router?
    Nothing wrong with my router; all the other laptops/iphones/ipads connected to it work :\

    On {xp, vista} run -> enter CMD and enter key; on Win/7 search -> enter CMD and enter key


    In the new command prompt window that results, enter IPCONFIG /ALL >myTCP.txt and enter key

    Now when you come back with a follow-up, COPY/PASTE the content of the myTCP.txt into your post

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : QinLaptop
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection 2:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
    Physical Address. . . . . . . . . : C4-46-19-72-5B-6F
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection 2:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom Virtual Wireless Adapter
    Physical Address. . . . . . . . . : 02-50-F2-00-00-01
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : DW1501 Wireless-N WLAN Half-Mini Card
    Physical Address. . . . . . . . . : C4-46-19-72-5B-6F
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::cc5b:2e1c:ba03:d59e%13(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.117(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Sunday, November 18, 2012 5:16:32 PM
    Lease Expires . . . . . . . . . . : Monday, November 19, 2012 5:16:38 PM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 247744025
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-DC-8D-33-B8-AC-6F-78-C9-B0
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Atheros AR8152 PCI-E Fast Ethernet Controller
    Physical Address. . . . . . . . . : B8-AC-6F-78-C9-B0
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::fc83:b89d:b3aa:e73f%11(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.3(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Sunday, November 18, 2012 5:16:30 PM
    Lease Expires . . . . . . . . . . : Sunday, November 18, 2012 6:50:20 PM
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DHCPv6 IAID . . . . . . . . . . . : 246983791
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-DC-8D-33-B8-AC-6F-78-C9-B0
    DNS Servers . . . . . . . . . . . : 209.18.47.61
    209.18.47.62
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{0D4CBEEF-E0F7-49ED-9202-0073689AE0BF}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{F0A4EA43-E85F-49B9-BDC8-5047FC3B08FC}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{BCF95610-C5D7-4BB0-8FE6-12A0D0A40C61}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:9d38:953c:28f5:1907:3f57:fffc(Preferred)
    Link-local IPv6 Address . . . . . : fe80::28f5:1907:3f57:fffc%15(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled
    Thanks so much!!
     
  4. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    Disconnect from LAN (remaining connected to wifi), and in a cmd window type "ping 192.168.0.1"
     
  5. jobeard

    jobeard TS Ambassador Posts: 13,516   +336

    There is a table in the networking software called the ROUTE table. When you get the first TCP connection
    (let's assume its the wired connection), an entry is made into it so transmissions from the PC go to your ISP - - this is called the DEFAULT route. Using your Ethernet adapter Local Area Connection data
    Code:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Atheros AR8152 PCI-E Fast Ethernet Controller
    Physical Address. . . . . . . . . : B8-AC-6F-78-C9-B0
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::fc83:b89d:b3aa:e73f%11(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.3(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Sunday, November 18, 2012 5:16:30 PM
    Lease Expires . . . . . . . . . . : Sunday, November 18, 2012 6:50:20 PM
    [B]Default Gateway . . . . . . . . . : 192.168.0.1[/B]
    your route table would then look like
    Code:
    Active Routes:
    Network Destination        Netmask          Gateway      Interface  Metric
    =>Default=>  0.0.0.0          0.0.0.0      192.168.0.1      192.168.0.3  20
            127.0.0.0        255.0.0.0        On-link        127.0.0.1    306
            127.0.0.1  255.255.255.255        On-link        127.0.0.1    306
      127.255.255.255  255.255.255.255        On-link        127.0.0.1    306
          192.168.0.0    255.255.255.0        On-link      192.168.0.3    276
          192.168.0.3  255.255.255.255        On-link      192.168.0.3    276
        192.168.0.255  255.255.255.255        On-link      192.168.0.3    276
    The Gateway is always the upstream router and to send anything to it, the NIC address of the PC is used (192.168.0.3). The Destination/Masks of 0.0.0.0 is what makes line one the default and the TCP software acts
    as if "if I don't know where it goes, send it to the default".

    Now if you get another connection (like trying to a the WiFi even though the LAN is already connected),
    you ONLY add one line to the existing table, like
    Code:
            192.168.1.117  255.255.255.0  onlink 192.168.1.117 
    The WiFi connection will not send any requests outbound but the DEFAULT route will still manage all TCP traffic though the Lan connection.

    CONCLUSION: Don't connect both wired and wireless at the same time - - One or the Other, NEVER BOTH
     
  6. Linda.

    Linda. TS Rookie Topic Starter

    Pinging 192.168.0.1
    Reply from 192.168.0.1: bytes=32 time=4ms TTL=63
    Reply from 192.168.0.1: bytes=32 time=55ms TTL=63
    Reply from 192.168.0.1: bytes=32 time=2ms TTL=63
    Reply from 192.168.0.1: bytes=32 time=3ms TTL=63
    Ping statistics for 192.168.0.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 2ms, Maximum = 55ms, Average = 16 ms

    Jobeard, I'm not sure if I understand what you're saying, sorry. I don't usually connect both wired and wireless; it's just that my wireless stopped working so I started connecting the wired. Even now, if I disconnect the ethernet cable, the wireless still does not work, and I'm not sure why..
     
  7. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    With wifi only connected, try:

    ping google.com

    then,

    ping 8.8.8.8


    And, let me get this straight - the wifi icon on Windows shows enough white bars, and NO alert icon..? Yet connecting to web pages doesn't work?
     
  8. Linda.

    Linda. TS Rookie Topic Starter

    Ping google.com brought up:
    Ping request could not find host google.com. Please check the name and try again

    ping 8.8.8.8 brought up:

    Pinging 8.8.8.8 with 32 bytes of data:
    Reply from 8.8.8.8: bytes-32 time=34ms TTL=53
    Reply from 8.8.8.8: bytes-32 time=29ms TTL=53
    Reply from 8.8.8.8: bytes-32 time=28ms TTL=53
    Reply from 8.8.8.8: bytes-32 time=27ms TTL=53

    Ping statistics for 8.8.8.8:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 27ms, Maximum = 34ms, Average = 29ms

    Wifi icon on Windows does show enough white bars! Sometimes there's an alert icon, sometimes there isn't.. Currently there isn't, though I swear there was one earlier today xD Connecting to webpages via wifi never works :\
     
  9. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    I think we're getting to the crux of the problem.


    Open Network and Sharing Centre. On the left side, click Change adapter settings. Right-click on your wifi connection (Wireless Network Connection - choose this, not #2), click Properties.

    Click on third option from the bottom - Internet Protocol Version 4 (TCP/IPv4). Click the Properties button. There are four radio buttons. Can you take a screenshot of this screen, please, and post here?

    If you like, choose: Obtain IP address automatically, and Obtain DNS server auto options, click OK and OK out of all the windows. Give it 2 minutes, and try ping google.com again.



    Edit: Once again, you need to do the above with wifi-only connected.
     
  10. Linda.

    Linda. TS Rookie Topic Starter

    Here it is!
    Also, ping google.com still isn't working.. Obtain IP address automatically was already selected, as well as Obtain DNS server auto

    Thanks so much :]
     

    Attached Files:

  11. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    Weird. Try this:

    1) ping 74.125.237.104

    2) Try manually entering DNS servers: 8.8.8.8 and 8.8.4.4. Then try ping google.com again.
     
     
  12. Linda.

    Linda. TS Rookie Topic Starter

    Here is the screen shot! The file was too large so I included the shot of my wifi signal >_< It looks fine, but I can't reach anything with it :\
     

    Attached Files:

  13. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    Sorry, I need to clarify 2)

    You need to go back to this point: "Open Network and Sharing Centre. On the left side, click Change adapter settings. Right-click on your wifi connection (Wireless Network Connection - choose this, not #2), click Properties.

    Click on third option from the bottom - Internet Protocol Version 4 (TCP/IPv4). Click the Properties button. There are four radio buttons."

    Then, click on the radiobox Use the following DNS server addresses: and enter 8.8.8.8 in Preferred, and 8.8.4.4 in alternate.


    Afterwards, try ping google.com in the command prompt. It should work, and so should browser.
     
  14. Linda.

    Linda. TS Rookie Topic Starter

    OH MY GOODNESS I LOVE YOU YOU ARE A GENIUS O__________________O
    Thank you so much! I have no idea how on earth this is working but you are a life saver :]
     
  15. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    Haha, yay. :)

    Although, this isn't an ideal solution. Would be best to find out why other wifi devices 'just work'. Also, would be better to replace 8.8.8.8 with the DNS servers your ISP provides.

    But, hey, if it works ..
     
  16. Linda.

    Linda. TS Rookie Topic Starter

    Would you know why it doesn't work with the previous settings that have once worked though? >_<
    And... "ideal"? does that mean that this is..not a good solution? XD

    Either way, ohmygoodness you're amazing
     
  17. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    It's not a perfect solution, but I think for your purposes it'll be 99.9% chance that it's fine.

    And no, I'm not sure why it suddenly stopped working. :( It'll have something to do with your router or modem too. I don't think either of us have the patience to type out directions and results for such in-depth analysis, haha.
     
  18. FBeans

    FBeans TS Rookie

    Hi St1ckM4n. I followed your tip and solved my problem on a used laptop recently acquired by a friend. Wired worked ok but not wireless. The wireless all looked ok and worked ok for other devices/PCs. I followed your tip and went to the properties and saw that for wireless it was set to a specific pair of IP addresses for DNS. So I instead changed the property and checked the radio button to "automatically obtain" DNS server. This is how the wired properties were set. Now wireless works fine. Don't know why wireless was set before to specific IP but changing to automatic fixed. Thanks again for posting your solution. It helped greatly!!
     
    St1ckM4n likes this.
  19. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    Ah, cool, very nice. :) Using the 'automatically obtain' is the preferred method for general home users, so great that this worked for you!
     
  20. AwaKe

    AwaKe TS Rookie

    I had the same type of problem, laptop suddenly stopped connecting to wifi even though wired connection was ok and every other devices worked fine with wifi. Manually changing the DNS adress to 8.8.8.8 and 8.8.4.4 worked on first try. I've been working on this for a few days and finally solved the problem.

    Thanks alot! :)
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.