... contains both secure and non-secure items

By gbhall
Jun 17, 2009
Topic Status:
Not open for further replies.
  1. This slightly irritating message always comes up when I browse certain perfectly safe sites - like my webmail for instance.

    'This page contains both secure and insecure items - do you want to display the non-secure items?'

    the non-secure items seem to be ornamental images. Unfortunately, there is no button 'don't show me this message again', as I vaguely feel there used to be.

    Is there any setting equivalent to 'belt up thanks, i know what I am doing....?
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    There is a browser setting for this:

    Open Internet Options (through Tools or Control Panel> Advanced tab> Security section> UNCHECK 'warn is changing between secure and not secure mode'> Apply> OK.

    That should handle it.

    Edit: This is path in IE6. You may have to adapt if later version.
  3. fimbles

    fimbles TechSpot Evangelist Posts: 1,193   +105

    [QUOTE} "Unfortunately, there is no button 'don't show me this message again', as I vaguely feel there used to be"

    Im pretty sure you are correct.. there should be a button.. weird :)
  4. gbhall

    gbhall TechSpot Chancellor Topic Starter Posts: 2,291   +40

    Thanks for that, Bobbye. I found it under Advanced tab (it has nothing to do with which browser you use, it's simply that you can start the internet properties app from within the browser). Didin't solve the problem though, it was already unchecked.....

    Notably, I run three browsers, and see this problem in IE7 and Avant browser, but NOT in Firefox 3. What does that tell me? That firefox is compliant with the internet security properties, but IE7 and Avant are not - and Avant happens to be my favourite, because of it's superb interface and because of the fact that it uses much IE7 internal dll's so it is more compliant with browser standards. (for instance it runs MS update just fine)
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    You're right of course. It's not a browser related setting.

    But I can't debate the compliance with you. I use Firefox almost exclusively- have for over 4 years, so I boss it around! I've never used Avant, but I tend to have all bad things to say about IE!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.