TechSpot

Counter Strike Source Mic problems

By RossoG
Oct 12, 2008
Topic Status:
Not open for further replies.
  1. Hey guys so this is my first post, I have CS:S on my brand new computer which is running vista, and I just bought a brand new headset microphone combo(logitech). Anyways the problem is when i enter a server my mic does not work. I have it plugged in correctly because i get the headphones working, and when i test the mic it picks up my voice all volumes are turned high, when im in the CS:S options and i test my mic it works, my in game voice is enabled and also the volumes are turned up max in the CS:S options. But whenever I join a game my mic does not work (but the headphones still do) anyways could someone please help me out here.

    Thanks
  2. iLag!!!!!

    iLag!!!!! Newcomer, in training Posts: 18

    If you're using a USB microphone:
    [​IMG]
    Go to sounds and multimedia properties, under control panel, and select the audio tab. Make sure where mine says Realtek HD Audio Input yours says USB Audio Device.

    If you're not using a USB microphone or your USB mic still doesn't work:
    [​IMG]
    Go to volume control, and make sure mic volume is muted, as circled in my screenshot.
    Now, click on options then properties.
    [​IMG]
    First, make sure the correct option is in the Mixer Device box and that the recording box is checked. Then, check all the options at the bottom of that screen. After you finish, hit OK.
    [​IMG]
    I've seen this screen presented in two different ways. It's either the way it is on my computer, with mute boxes, or there's a select box which can only be activated for a single device. Either way, make sure that everything is muted except for microphone, or that microphone is selected, and make sure the volume is turned up.

    If your problem still isn't solved, post.
  3. RossoG

    RossoG Newcomer, in training Topic Starter

    Thx for responding Ilag but I dont understand how you get these windows up? On vista when i go into control panel there is only sound not sounds and multimedia. When I open sounds i get playback recording and sound tabs. Under recording i have my mic selected and the volumes turned all the way up ive looked but i cant find any of the windows you have shown above.
  4. iLag!!!!!

    iLag!!!!! Newcomer, in training Posts: 18

    It you're on vista then it's no wonder you have problems. I am proud to say that I haven't touched a vista yet and have no plans on doing so in the near future, since thety screwed with EVERYTHING. You'll need someone experienced with Vista to help you. Sorry I can't.
  5. RossoG

    RossoG Newcomer, in training Topic Starter

    Thanks for your help though! Can someone with vista please please help me out... i just want to be able to talk while in cs.
  6. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,366   +167

    First thing to check
    What's Sound Recording doing? Find it in Sound Control Panel (will be something like)
    => click Recording -> microphone -> Properties -> Advanced

    => Look for the option Allow applications to take exclusive control of this device It must be unchecked

    And to iLag!!!!!
    Nice collection of examples / images in your post :)
  7. RossoG

    RossoG Newcomer, in training Topic Starter

    alright i did that hopefully it works now ill post if it works or not.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.