CPU problem?

By codewahn
Jan 9, 2012
Post New Reply
  1. ok so few days ago i got a new cpu, everything was fine and awesome, today all was going fine untill i turned my comp off to go out, i came home and turned my comp on and nothing, no display no picture after a while of trying it turns on and works tho 10 min later i get white screen and then its back to doing nothing, so put my old crappy cpu in and comp works fine, so question is, is the cpu faulty and in need of a replasement?

    cpu is a intel core 2 quad
    mb is a gigabyte g31m-es2l

    so i know it is compatible
  2. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 5,773   +1,429

    Its possible there could have been a bad connection with the CPU. Have you tried putting it back in, to make certain it does not work after being re-seated?
  3. codewahn

    codewahn Newcomer, in training Topic Starter

    yea, tryd about 4 times to reinstall it and try get it working
  4. JC713

    JC713 TechSpot Evangelist Posts: 6,725   +874

    Compatibility

    Did you install it properly? Push it in completely so that all pins are in. Also, consider replacing the motherboard and getting a refund on the core 2, get an i3, or even and i5 or i7, and another mobo, plus make sure you have at least 4gb of memory, but the quad needs 2gb ddr2 i believe
  5. codewahn

    codewahn Newcomer, in training Topic Starter

    yes im sure, it was working fine for a few days then died on me, i have 4 gig ram, and cant really afford to build a new comp atm even tho i plan to build a mid-high comp


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.