TechSpot

CPU running at 100%

By Twigkat
Jun 5, 2007
  1. Help!! I'm trying to help out a non-techie neighbour with their computer...

    I've seen this issue elsewhere and understood it was a windows updating problem. So I installed the recommended hotfix (927891) but I still have issues.

    see here and here for more information.

    Any tips gratefully received asap if possible!!

    Many thanks in advance...

    T
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,450   +324

    for starters, everything associated with CTFMON.EXE is bogus and totally unnecessary. Disable or delete the service via hijackthis.

    run the taskmgr, click on the CPU column twice to get the hi-cpu users to the
    top of the display.

    which program(s) are eating the cpu?
     
  3. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 23

    Hello - thanks for your reply. Checking out this link reveals this file has something to do with office, so I'm checkingthat out initially.

    It is a svchost.exe file that is eating up the CPU. However realising that there is only 256 RAM running lots of different programs on the system, it may well be high time for some extra RAM in their machine.... next job is to find the relevant RAM chip! Any tips?

    Thanks again! Much appreciated.
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,450   +324

    CTFMON is from Broadcom and is a feedback agent; ergo unnecessary.

    I too run office and have disabled CTFMON long ago without ill effects.

    the svchost is the update issue reported in the KB article.
    You're just stuck with the issue. You can only attempt to disable as many
    auto-updaters as possible.

    more memory would be a benefit, but don't expect to reclaim any CPU cycles.
     
  5. jobeard

    jobeard TS Ambassador Posts: 13,450   +324

  6. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 23

    svchost.exe running at 100%

    OK, have done that, also tweaked the language settings via control panel as that was another recommendation. Also checked all start-up programs and disabled a few of the more obvious ones (java updates was also set up run automatically).

    Then having given the pc another registry clean etc., I then went into microsoft updates to see what would happen. Left it running all night long and it was still checking this morning.

    So something else must be wrong otherwise it would have found the updates before now! Yes, I have seen some of that info regarding cftmon but have disabled the processes for now.
     
  7. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Is svchost still using 100% of the CPU? Disable the Automatic Updates service to make work a little bit easier.

    Now, uninstall and reinstall the AU system:
    Make sure the Background Intelligent Transfers and Automatic Updates services are stopped.
    From command line, run "regsvr32 /u wuaueng.dll"
    Remove all files in WIndows\SoftwareDistribution
    Remove WIndows\windowsupdate.log
    run "regsvr32 wuaueng.dll"
    restart the AU and BITS services
    run "wuauclt.exe /resetauthorization /detectnow"
     
  8. Twigkat

    Twigkat TS Rookie Topic Starter Posts: 23

    Well it's getting there - see here for my log

    CPU seems to behave itself - so I'm getting there!!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.