CyberLink PowerDVD Problems

By PC_Nerd
Mar 19, 2007
  1. I have had PowerDVD 6.0 OEM edition for some time, it worked perfectly fine.
    I recently tried to install PowerDVD 7.3 Ultra Deluxe.
    It wouldnt install because 6.0 couldnt initialise setup.
    I deleted all folders, files and registry keys relating to Cyberlink.
    Installed 7.3 just fine.
    I take note of the fact that Microsoft SQL server Desktop Edition needs to configure during installation (this was left behind from Sony ACID Pro).
    When I try to configure it, and I confirm, it hangs the whole system, requiring me to hit the reset button.
    I uninstall 7.3, reinstall 6.0.
    6.0 Hangs after configuration.
    I think.
    I uninstall Microsoft SQL Server Desktop Edition and all other crap ACID left behind, (namely, although it is a bit grey, 'user-mode driver framework or something' and 'windows something compression').
    Reinstall 6.0.
    Still hangs after config.
    Any ideas? I want either this to work or a comparable alternative to consider.

    I have
    AMD XP 3000+
    1gb pc3200
    nv 7600gs
    gforce 2 chipset
    onboard ac '97 sound
    all latest drivers

    Any help would be very apreciated.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...