Dang it

By smoothmule
Aug 28, 2009
  1. I'm new to this forum. I have been desperately searching for help online and after looking through the posts, I thought someone here might be able to help.

    Background: Computer was in one of our storage units and left behind when they couldn't pay (not a good thing I know).
    It's a Compaq Presario SR2150NX, VISTA, no hardware added that wasn't factory from what I can tell.

    Problem(s): Number one is that Nothing on the screen at all. Just blank Problem Number 2, the CD-ROM opens on start up by itself.

    I don't know if these problems can be related but I'd love some help. The graphics card is the integrated type so I thought getting a new card might help. I added some memory, 2 GB total. I got an NVIDIA GeForce 9500 GT and physically installed it but nothing happened when I turned it on, still blank on the monitor and there's still that issue of the CD-ROM opening automatically when I turn the computer on. I tried putting a CD in and closing it, it lit up like it was trying to read it and then opened up again on it's own like it was spitting out something that tasted bad :p

    Is there anything else that could cause the monitor and computer to not communicate besides the graphics card? How can I install this new card/drivers when I can't see anything on the screen? I did a quick search in this forum and didn't find anything I thought would help. What size power source does this graphics card need? I think the one it has is 300w, can that be an issue?

    What am I missing?
  2. EXCellR8

    EXCellR8 The Conservative Posts: 1,835

    just a question, what happens when the original owner wants the computer back and has the money to retrieve it from storage?
  3. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,219   +157

    I would guess that after 6 mos,and a court date, they surrender their property?
    thats how it works here in MN anyway
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,689   +395

    I think the best thing to replace on it is the power supply, it is far more likely that that is bad than anything else. Bad power supplies can still power things, a bad one can even boot up a system fully, but its unreliable. The CD Drive opening on boot doesn't sound good though, that could be because of some weird issue with the motherboard, but I would definately look at the power supply first. The very worst thing that can happen is you get a new PSU and it doesn't fix the computer, and then you just have a spare. I think about any other thing you try and fix/replace will be less likely to be the problem and more expensive to deal with.
  5. smoothmule

    smoothmule TS Rookie Topic Starter

    The storage unit had been abandoned a while past the date to surrender. We have this happen fairly often and have never had anyone come back wanting to pay up to get their stuff, that always amazes me. It's not like the belongings have been pawned and they can come back later and we have to hold it for them in case they want to try to get it back like a pawn shop. We need to be able to rent out the unpaid for unit as quickly as we can and most usually, the whole unit is full of trash that we have to dispose of and clean the unit. That's even more puzzling, some of these units have been paid up for months and months and nothing in them but trash then they just disappear......some of the personal stuff isn't really trash, it's just nothing anyone else would want. We had a unit with loads of old photos and memorabilia from being in the Army and we sorted it all out and tried to find the owner to give it to them but was never able to locate anyone, sad.

    Thanks for the help. I was told I might need a 600w to replace the 300 for this card. I do have another power source to try, but it's just 300watts too. Should I try it?

    As far as the CD-Rom, should I bother trying another one? Or does opening on it's own sound more like motherboard problems? I inspected the motherboard for anything out of place. There wasn't any smell like something burnt out, nothing bulging or popped out, everything seated in right, etc.

    Also, I don't have any experience with this type of graphics card. The instructions were pretty generic that came with it. I couldn't find any place on it for a power supply to be plugged in, does it have one? And, there was a place on the outer side that had a little notch that looked like where you might plug it into the board but on the outer side, what is that for?

    Thanks again guys
  6. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    I've had bad ROMS weird out the whole system. Disconnect it and try booting. Also is there onboard video that hasn't been disabled in the BIOS? Can you even boot into the BIOS and see it? if there is a power plug on the card it should be on the end and be a 6 pin. I doubt the PSU has a connector but you can buy an adapter. 300W might not be enough. Since it is a Compaq it may have a proprietary power supply connector. That is a new power supply off the shelf may have the wrong wire config on the 20 pin connector.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...