Delayed write failed

By imabcd
Nov 27, 2010
Post New Reply
  1. i had problems in my pc so i formatted c drive .. 2 days ago .after that i started installing setup's and updating my pc . i have 2 hard disk one of 160 gb and other of 1 tb .everything was going well and a message came in the right hand corner of the task bar that (windows -delayed write failed . the data could not be saved try copying it over another drive . ) there were various errors regarding this on different drives .

    only in the second harddisk of 1 tb .there was delayed write failed error in k drive and in i drive .i went to c -properties-hardware- selected the harddisk - went to properties there and unticked enable write caching on disk .

    but after some time the error again popped up and my pc hanged . i restarted and chkdsk came up and scanned h drive i drive . and there was errors it cleaned some of them and also said that insufficient space to recover lost files . after that the windows started and to my suprise the second hard disk of 1 tb was not there . i restarted and tried again but to no avail . i can access my pc but everytime the chkdsk comes up and also my 1 tb hard disk is not there .so guys plz help me :(
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,327   +49

    Sounds as if the bios is not properly accessing the 1TB drive. Start the bios as required usually delete key at boot, but can be other key. Is the 1Tb drive recognised in the bios? At worst, it could be a failed drive. Test for that is obviously mount in another PC.
  3. imabcd

    imabcd Newcomer, in training Topic Starter

    i didnt quite understood what you said .well after i press delete key the system setup screen comes up so what do u want me to do there ?
  4. jobeard

    jobeard TS Ambassador Posts: 13,275   +280

    1TB devices must use the LBA access.

    I'm thinking maybe what is NOT enabled is "LBA". But what puzzles me is that these days ALL drives use the second-generation version thereof, called "48-bit LBA", so your BIOS should have got that message from the HDD and automatically enabled it.

    Check in BIOS whether LBA is enabled on your drive. On the main BIOS Setup start-up screen, try using the option to Auto-Detect your drive to force it once again to get the drive's info from it
  5. jobeard

    jobeard TS Ambassador Posts: 13,275   +280

  6. imabcd

    imabcd Newcomer, in training Topic Starter

    ok i removed the wires of the hard disk and attached it again and now it detects the disk .:)
    thank u anyways


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.