Dell Inspiron 1501 no charge, no boot, no nothing

By mousetopher
Jun 15, 2009
  1. I have a Dell Inspiron 1501 Laptop - the original Dell AC Power Adapter crapped out and was replaced with a universal Targus adapter. This powered the laptop well for approximately two weeks, however the laptop stopped working overnight and now refuses to boot.

    When I plug in the adapter, no lights appear. The laptop does not respond in any way when I push the power button, it doesn't matter if it's plugged in, not plugged in, battery in, battery out. The charging port on the machine does not appear to be loose. The adapter comes with a handful of different tips, and was tested on my Acer Aspire and is in good working order.

    I've read that this model laptop (or maybe just Dells in general) has issues with universal/aftermarket chargers, but in those cases the laptop will generally still run off AC power even if the batteries won't charge. I read somewhere else that these symptoms point to a fault with the internal power supply board, but I don't even know what that is or what it looks like.

    If anyone has any information on this problem, or on troubleshooting and repairing a PSB fault (if that even matches my symptoms) it's very greatly appreciated. :)

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Yes, you probably damaged the charging circuits/motherboard by using an after-market AC adapter... These charging circuits may be part of a $300+ motherboard. Good luck
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...