TechSpot

Dell Inspiron 6000 - internal HDD

By cw100
Sep 11, 2010
Post New Reply
  1. Hello, I am new here and came across this forum while googling for tips on getting my Dell Inspiron 6000 fixed. This forum seems very helpful from what i've read and so I thought I should post my problem to see if anyone can suggest a solution to me.

    I recently was watching a video file on my laptop when the computer just shut down. When I try to reboot now, I get an error message saying "Internal HDD Hard error! Strike the F1 key to continue, F2 to run the setup utility". When I hit F1 with my windows install disk in the CD-rom drive, I get an error saying that there is no Hard Disk Drive recognized and to make sure that the Hard Drive is powered on, etc.

    I thought that maybe my hard drive had died on me so I purchased a new hard drive and it is the same exact problem still occuring. Any tips or links on what I might need to do would be very helpful...Thanks for your time!
  2. hughva

    hughva TS Rookie Posts: 309

    Most Dells have a diagnostics program (F12 at boot).
    Run the tests and see what they say.
  3. cw100

    cw100 TS Rookie Topic Starter

    Thanks for your reply. At boot, my 2 options are:
    f2 is setup
    f12 is boot menu

    When I hit F12 it says "Preparing one-time boot menu" and then the same error occurs on the very next screen....
  4. hughva

    hughva TS Rookie Posts: 309

    Try F2 and see if the HD is shown in the BIOS.
  5. cw100

    cw100 TS Rookie Topic Starter

    Same thing happens when I hit F2...it takes me to the screen that says
    "Internal HDD Hard error. Strike F1 to continue, f2 to run the setup utility"

    Then if I hit F1 it says "No bootable devices. Strike F1 to retry boot, F2 for setup utility"

    When I am finally able to hit F2 for setup utility, the only thing I see for "BIOS" is says "Bios Version A08 (7-22-2005)" under the system info.
  6. hughva

    hughva TS Rookie Posts: 309

    You should still be able to get into the BIOS, even without a HD.
    Still, you have a problem with the HD and probably need to replace it.
  7. cw100

    cw100 TS Rookie Topic Starter

    I ordered and put in a brand new hard drive and still have the same problem so do you think its a problem with a connection to the hard drive?
  8. hughva

    hughva TS Rookie Posts: 309

    Have you installed an operating system?
  9. cw100

    cw100 TS Rookie Topic Starter

    I have not installed an operating system on the new hard drive because the dell is not recognizing the drive as being there (same problem as the old hard drive) so it will not allow me to install the operating system. I think there is some short somewhere between the hard drive connection to the computer.

    I put the Windows XP CD-rom in the drive and I get to the point of hitting enter to install windows, "r" to repair windows", etc. When I hit enter to install windows I get a message stating that there is no hard drive available to install Windows on and that the laptop will power off in 15 seconds.

    Just out of curiosity I plugged my external hard drive that I store music on into the Dell and it gives me the option to install windows on that hard drive and still doesn't read the new hard drive or the old hard drive as existing so it sounds to me like there is a problem somewhere between the internal hard drive and the connection to the computer. Is there a way to either install windows on an external hard drive and boot the laptop up that way? I didn't want to continue with my current external hard drive because I did not want the windows installation to wipe out all the music I have stored on that particular external.
  10. hughva

    hughva TS Rookie Posts: 309

    Is tis a SATA or PATA drive?
    Have you tried connecting it to another controller?
  11. cw100

    cw100 TS Rookie Topic Starter

    I am pretty sure it's a PATA drive and I don't know how to connect it to another controller. help..?
     
  12. hughva

    hughva TS Rookie Posts: 309

    This is a laptop, so there's only one controller (My bad).
    Try getting into the BIOS again. If you still can't, I'd have to assume some kind of motherboard problem.
  13. cw100

    cw100 TS Rookie Topic Starter

    I got into the bios and listed under device info the following appears as the first line
    Primary Hard Drive = {none}

    I was also able to run the diagnostics and ran into errors:

    START DST SHORT TEST
    TEST RESULTS: FAIL
    ERROR CODE: 1000-0141
    MSG: NO DRIVE DETECTED

    the I continued with the diagnostic and got this......

    NO DIAGNOSTIC UTILITY PARTITION FOUND. TO RUN DIAGNOSTICS, INSERT YOUR DELL "DRIVERS AND UTILITIES" CD, THEN SELECT OK TO RESTART THE SYSTEM AND BOOT OFF THE CD

    Is there some connection problem between the motherboard and the hard drive?
    What should I do from here? I still cannot find anyway to load windows on the hdd........
  14. hughva

    hughva TS Rookie Posts: 309

    I don't know of anything else to do.
    If the drive is properly connected and undetectable, part of your motherboard has failed, probably the drive controller.
    I'm not 100% confident in this, so maybe someone with better hardware knowledge will join in.
  15. cw100

    cw100 TS Rookie Topic Starter

    Thanks, I appreciate your help!


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.