TechSpot

Dell motherboard/ATI 4850 issue

By xwarriorx
Nov 7, 2009
  1. hi guys,
    i'm wondering if dell's motherboard could affect ati 4850 in-game performance(low fps on any settings and serious lags after 30 minutes of gameplay)?
    i've made some sort of investigation and it seems that:1)after video drivers update there's still issue with ingame performance(fps mainly).it doens't matter what settings i play,it's still there;2)i've compared my gaming system with some other more or less similar ones which are owned by my bro and friend.they could play any 09' game on max settings with high fps.their systems are custom built ones;3)i've read through different tech forums and it seems that some xps owners are not happy with their systems,at least with motherboards.
     
  2. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 2,288   +7

    I presume that card is on a PCI-E 2.0 x16 slot. The issue could well be your PSU. What are the exact specs of your PC?
     
  3. xwarriorx

    xwarriorx TS Rookie Topic Starter Posts: 39

    yeah card is mounted on that slot as it was assembled on dell's factory.PSU is antec 650watt.i had 375 watt dell's one before.point that after i installed this PSU, overall game performance increased but not exactly on the level, i expect from the system.the spec are quadcore 8300 2.5 mhz,ati hd 4850 with 512 mb,4gb ram,anter psu 650 watt,dell''s motherboard(dunno the model name,besides it's not even mentioned on provided document package).
     
  4. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 2,288   +7

    Maybe you're having overheating issues? Have you checked your GPU and CPU temperatures?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.