TechSpot

Difficult networking problem - Please help

By tnstisser
Dec 23, 2008
  1. I've got a difficult problem that's I've been working on for days.

    System: emachines running Windows XP Home Edition.
    OS: Windows XP Home Edition - SP3 - all updates current
    Connection: Cabled network connection via onboard Intel Pro/100 VE network adapter
    Router: Linksys
    Modem: Surfboard

    This system has been functioning in my current configuration for several years. The current symptoms are that it will boot fine, network diagnostics complete successfully, ping works to local and remote hosts, Skype connects and funtions, Windows Messenger connects OK.

    Problem: No internet connectivity can be made via a browser (neither IE7 or Firefox) It goes through the connection attempt (resolves IP address), then times out.
    (Note: several other computers in household share same router and work fine)

    Background: Problem originated after uninstalling CA Internet Security Suite 2007, uninstall was messy as it did not uninstall cleanly and had to be removed with 3rd party tools. This originally broke all network connectivity, but I was able to restore limited connectivity (would work for only 2-3 minutes after each reboot) by uninstalling and reinstalling the network adapter, then resetting Windows firewall setting to default. I was then able to connect to the internet long enough to use CA's online removal tool that is supposed to remove all traces of the Security Suite and clean up the registry. I also made sure that I have all current Windows Updates, scanned for viruses, malware, and spyware. After additional fix attempts, all internet connectivity was lost.

    Current state: As mentioned previously, I cannot connect via a browser to any websites. Skype and Messenger still work.

    Remedies tried thus far:
    - Updated network adapter driver with latest version, then rolled it back to previous version once it had no impact
    - Reloaded the CA Internet Security Suite 2007 software that originally caused the problem when removed. Uninstall again failed and I had to work with CA Technical Support to get a utility to completely remove all traces of their software. They then stopped providing support and thought it was a winsock problem.
    - Reset Winsock via netsh winsock reset command and via WinsockFix.exe
    - Reset TCP/IP using netsh command
    - Reset firewall to default settings (Windows firewall is currently off)
    - Diabled, uninstalled, then reinstalled Network Adapter
    - Tried different ethernet cable
    - Reset modem and router
    - Manually loaded default gateway and DNS servers into TCP IP properties
    - Tried all steps outlined in http://support.microsoft.com/kb/314067/
    - Flushed DNS and restarted DNS and DHCP Services
    - Downloaded and ran all features of Dial-a-Fix utility
    - I've also tried restoring to previous restore points, but all restore points prior to the problem have been lost by various fix attempts.

    I'm running out of ideas and have searched the web for any similar problems, but have been unable to find anything I haven't already tried.

    I would deeply appreciate any help anyone could provide from this forum.
    I've attached my most recent Hijackthis log.
     
  2. tnstisser

    tnstisser TS Rookie Topic Starter

    I forgot to mention that I have also tried LSP-Fix
     
  3. tweaks_sav

    tweaks_sav TS Rookie Posts: 186

    One way I diagnose if it's hardware or software is by booting to Ubuntu off CD and seeing if I can use the internet.
    If Internet works, then it's software. You have already tried everything I would suggest to do. Have you tried a repair install of XP?

    If the Internet doesn't work in Ubuntu, it may be hardware. Have you tried a brand new Network Adapter? PCI Ethernet Cards are cheap, if you need one to test.
     
  4. tnstisser

    tnstisser TS Rookie Topic Starter

    Toby,

    Thanks for your reply. I downloaded UBUNTU this morning and tried it - internet works fine with UBUNTU, so that eliminates the possibility of hardware problem. I also downloaded ComboFix.exe and ran it, but it didn't help either.

    Unfortunately, I don't have the Windows XP Installation CD for Home Edition (only have XP Pro), so I don't think I can do a repair install of XP. That would probably to a good thing to try though. I'm still pretty convinced from what I've researched that the botched uninstall of CA's Personal Firewall is what did the damage to something in the registry, but I can't figure out what or how to fix it.

    Let me know if you have any other suggestions or know how I could do an XP repair install without the installation CD.

    Terry
     
  5. tnstisser

    tnstisser TS Rookie Topic Starter

    Another update.

    I also just downloaded Windows XP Servie Pack 3 and burned it to a CD then reinstalled it on the problem PC. STILL no internet connectivity !!

    I'm still looking for a Windows XP Home Edition CD to try a repair install, but I'm becoming more doubtful about it being able to help. I'm still thinking something is messed up in the registry that the updates and repairs are not fixing.

    If anyone has any ideas, I'd welcome them. I'll probably give up and reload Windows from scratch soon. But I hate to because then I won't have learned anything...

    Terry
     
  6. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

    Your DNS settings are wrong or a virus has hijacked your system.

    see basic networking

    if you can ping 74.125.19.47 and get timings
    but ping www.google.com fails,
    this confirms the above.
     
  7. tnstisser

    tnstisser TS Rookie Topic Starter

    J.O. - Thanks for looking at my post.

    Yeah, I originally suspected a DNS problem, but Network Diagnostics completes with no errors. I can ping local and remote hosts by name or by IP address. DNS servers are known and correct, etc. I flushed the DNS and reloaded it along with DHCP just to be sure, but nothing helped.

    That's what makes this problem so strange. All the network connectivity seems to work except being able to access sites via a browser. Windows firewall is currently turned off.

    I have scanned for all viruses, spyware, malware, etc with 2 or 3 different tools and found nothing besides a few harmless tracking cookies, etc. The machine has always had current anti-virus software loaded and running.

    I know something simple should fix this, but I'll be darned if I can find it...

    Terry
     
  8. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

    then TCP is find and we suspect the browser being hijacked -- which browser(s)?
    One or all of them?

    start this process
     
  9. tnstisser

    tnstisser TS Rookie Topic Starter

    J.O.

    No browser will work. I have been using IE7, but I even installed a fresh version of Firefox (never previously installed) after the problem developed to further troubleshoot the problem and it doesn't work either.

    I looked at your referenced link to troubleshoot for malware, viruses, etc.

    I have been using CCleaner, MalwarewareBytes, EasyCleaner, Spybot Search & Destroy, Norton Anti-virus for the past week and have run numerous scans. My original post contains a HijackThis log following those scans. I can go through your exact referenced step by step process if you think it will be more beneficial.

    Regards,
    Terry
     
  10. tnstisser

    tnstisser TS Rookie Topic Starter

    Completed another round of virus scans and new logs attached

    J.O.

    OK, I had some time so I followed all the steps in your referenced 8-step Viruses/Spyware/Malware Preliminary Removal Instructions.

    I have attached the mentioned log files from MalwareBytes, SuperAntiSpyware, and HijackThis

    Thanks to all for any assistance.

    Terry
     
  11. davidqxo

    davidqxo TS Rookie

    I've not looked at your logs, but I believe you have the correct diagnosis. That sounds just like something that happened to me a few years ago. It was some other firewall. I'm sorry I've so far been unable to dredge up exactly the fix. I believe it involved removing all the network services (located under Properties for the connection in question), then reinstalling them.

    Good luck.
    --David
     
  12. tnstisser

    tnstisser TS Rookie Topic Starter

    David,

    I think I've already tried what you're talking about. I have disabled my network adapter, then uninstalled it completely. Upon reboot, it detects it and reinstalls it from scratch. This still doesn't help. Strangely, earlier in my troubleshooting phase, this action (along with reloading the Firewall setting to factory defaults) enabled the brower to work - but for only 2-3 minutes after each reboot, then it would stop working again. Subsequent fix attempts returned me to no browser connectivity at all, and I have been unable to recreate the partial fix condition.

    Let me know if you remember anything else about your former situation and fix.

    Thx,
    Terry
     
  13. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

    There are some issues in the registry :
    Adware.MyWebSearch/FunWebProducts
    HKU\S-1-5-19_Classes\SOFTWARE\Fun Web Products
    HKU\S-1-5-20_Classes\SOFTWARE\Fun Web Products HKU\S-1-5-21-2774533042-4042934319-4010050463-1003_Classes\SOFTWARE\Fun Web Products​

    entries:
    O2 - BHO: (no name) - `B8ED58-01DD-4d91-8333-CF10577473F7} - (no file)
    O2 - BHO: (no name) - B56D79-679B-4b4c-8E49-5AF97014F4C1} - (no file)

    O16 - DPF: Aces Up! by pogo - http://game1.pogo.com/applet-6.5.4.34/aces/aces-en_US.cab
    O16 - DPF: Battle Phlinx by pogo - http://game1.pogo.com/applet-6.6.5.22/battlephlinx/battlephlinx-en_US.cab
    O16 - DPF: Blackjack by pogo - http://game1.pogo.com/applet-6.5.4.34/blackjack/blackjack-en_US.cab
    O16 - DPF: Dice Derby by pogo - http://game1.pogo.com/applet-6.6.2.35/checkeredflag/checkeredflag-en_US.cab
    O16 - DPF: Dominoes by pogo - http://game1.pogo.com/applet-6.6.4.21/domino/domino-en_US.cab
    O16 - DPF: First Class Solitaire by pogo - http://game1.pogo.com/applet-6.5.4.34/firstclass2/firstclass2-en_US.cab
    O16 - DPF: Fortune Bingo by pogo - http://game1.pogo.com/applet-6.6.2.21/superbingo/superbingo-en_US.cab
    O16 - DPF: Greenback Bayou by pogo - http://game1.pogo.com/applet-6.6.2.21/greenback/greenback-en_US.cab
    O16 - DPF: Harvest Mania by pogo - http://game1.pogo.com/applet-6.5.4.34/harvest/harvest-en_US.cab
    O16 - DPF: Jigsaw Detective by pogo - http://game1.pogo.com/applet-6.6.2.21/jigsaw/jigsaw-en_US.cab
    O16 - DPF: Jungle Gin by pogo - http://game1.pogo.com/applet-6.6.4.21/gin/gin-en_US.cab
    O16 - DPF: Lottso by pogo - http://game1.pogo.com/applet-6.6.4.29/lottso/lottso-en_US.cab
    O16 - DPF: Mah Jong Garden by pogo - http://game1.pogo.com/applet-6.6.2.21/mahjong/mahjong-en_US.cab
    O16 - DPF: Multiline Slots by pogo - http://game1.pogo.com/applet-6.6.4.21/mlslots/mlslots-en_US.cab
    O16 - DPF: Penguin Blocks by pogo - http://game1.pogo.com/applet-6.5.4.34/penguins/penguins-en_US.cab
    O16 - DPF: Phlinx by pogo - http://game1.pogo.com/applet-6.6.5.22/flinger/flinger-en_US.cab
    O16 - DPF: Pop Fu by pogo - http://game1.pogo.com/applet-6.6.0.27/popfu/popfu-en_US.cab
    O16 - DPF: PoppaZoppa by pogo - http://game1.pogo.com/applet-6.5.4.34/poppazoppa/poppazoppa-en_US.cab
    O16 - DPF: Poppit by pogo - http://game1.pogo.com/applet-6.6.5.22/poppit2/poppit2-en_US.cab
    O16 - DPF: Quick Quack by pogo - http://game1.pogo.com/applet-6.5.5.29/hotstreak/hotstreak-en_US.cab
    O16 - DPF: QWERTY by pogo - http://game1.pogo.com/applet-6.6.4.21/squares/squares-en_US.cab
    O16 - DPF: SciFi Slots by pogo - http://game1.pogo.com/applet-6.6.4.29/slots/scifi-en_US.cab
    O16 - DPF: Showbiz Slots by pogo - http://game1.pogo.com/applet-6.5.4.27/slots/showbiz-en_US.cab
    O16 - DPF: Spider Solitaire by pogo - http://game1.pogo.com/applet-6.6.4.29/spider/spider-en_US.cab
    O16 - DPF: Squelchies by pogo - http://game1.pogo.com/applet-6.6.0.34/squelchies/squelchies-en_US.cab
    O16 - DPF: Stax by pogo - http://game1.pogo.com/applet-6.6.4.21/stax/stax-en_US.cab
    O16 - DPF: Tri-Peaks by pogo - http://game1.pogo.com/applet-6.6.0.34/peaks/peaks-en_US.cab
    O16 - DPF: Tumble Bees by pogo - http://game1.pogo.com/applet-6.6.4.21/jumbee/jumbee-en_US.cab
    O16 - DPF: Wonderland Memories by pogo - http://game1.pogo.com/applet-6.5.5.29/memories/memories-en_US.cab
    O16 - DPF: Word Whomp by pogo - http://game1.pogo.com/applet-6.6.2.21/wordwhomp2/whomp2-en_US.cab
    O16 - DPF: Word Whomp Whackdown by pogo - http://game1.pogo.com/applet-6.6.2.21/whackdown/whackdown-en_US.cab
    O16 - DPF: WordJong by pogo - http://game1.pogo.com/applet-6.6.4.21/wordjong/wordjong-en_US.cab
    O16 - DPF: World Class Solitaire by pogo - http://game1.pogo.com/applet-6.6.5.22/worldclass/worldclass-en_US.cab
     
  14. tnstisser

    tnstisser TS Rookie Topic Starter

    OK guys - thanks to all that helped look at my problem. I finally ran out of patience and gave up trying to repair it today and reloaded Windows XP. Guess I'll never know what it would have taken to actually repair the problem...
     
  15. monton

    monton TS Booster Posts: 110

    Had similar problem on an XP Pro computer. Spent ridiculous amount of time trying to connect. Copied all files I needed, installed Ubuntu 8.10. Computer works flawlessly. Problem solved.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...