Dimension 4600C Power Supply Problem

By Sanuk9
Oct 14, 2006
  1. Hi,

    My first post here will of course be about a problem. Specifically, my Dimension 4600C will no longer power on. This problem began after I replaced the old hard drive (removed defective one and installed Seagate 160GB IDE drive). After completing this replacement, I found I was unable to power on the computer.

    One observation I have made (after 2 hours on phone with Dell) is that if I remove the two RAM components, the computer will power on and make numerous beeping noises. However, when the RAM is in I am unable to turn on the computer.

    I have also tried reinstalling my old Hard Drive, and now even with this one the computer will not power on.

    Any guesses as to the problem? Any thoughts on other troubleshooting steps or potential solutions?

    Many Thanks,
  2. Rik

    Rik Banned Posts: 3,814

    According to some information i googled, your power supply is only a measly 160 watts. The 160gig hard drive may have been too much for it to handle!!!!

    See if it will start with no hard drive, if not, leave the mains plug out for at least 20 seconds and try again!!!!

    NFSFAN TS Rookie Posts: 245

    The HDD should not be a problem. They consume only 30 Watts. But 160 Watts is too low. I reccomend at least 300 Watts
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...