TechSpot

DirectX problem

By willo51100
Apr 22, 2008
  1. Hello I don't know anything about computers and I bought an old game which doesn't work because I need to have DirectX v5.0 for it to work but when I try to install DirectX v5.0 with the game cd it says directX is fully installed. Of course my game still doesn't work and I've tried several times to uninstall and reinstall the game without success.
    Could someone please help me?

    Here is my email adress if anyone knows anything that could help me
    Thanks
     
  2. mailpup

    mailpup TS Special Forces Posts: 8,484   +233

    Well, you've given virtually no information to go on, not the name of the game, no PC specs, no operating system, no nothin'.

    So flying blind, I'll venture a guess that the old game was published circa the Windows 98 era and you currently are running Windows XP. If I'm close to being correct, one fix to try would be to change the compatibility mode in the current PC. Also, be sure to install any and all game patches that may have been released.

    In XP DirectX 9 is supposed to be backwards compatible with earlier versions of DirectX.
     
  3. willo51100

    willo51100 TS Rookie Topic Starter

    yeah sorry about that first time! Here are some PC specs:
    CPU: Intel Core 2 Duo T5300
    Mem: 2GB
    Video:ATI Radeon X2300
    OS: VistaPremium
    Now, the game is The curse of Monkey Island and was published in 1997 so you were quite close! ;p I don't know if it works with Vista but could you explain how to change the compatibility moden the pc? I have another computer at home which runs with XP so I could change the compatibility on that one.
     
  4. mailpup

    mailpup TS Special Forces Posts: 8,484   +233

    In Windows XP there are two ways to change the compatibility mode. The easiest is to create a desktop shortcut icon for the game if one isn't already there and right click on it. Alternately, you can right click directly on the game .exe file. On the menu that appears, left click on Properties. There should be a Compatibility tab that appears. Click on it and select a compatibility mode to try (Windows 98, NT, etc). Save/apply it and try running the game. If one doesn't work or work well, try another.

    The second method is a little more complicated but I think it's better. Click on All Programs in the Start menu and click on Accessories. Enter the Compatibility Wizard. The advantage of the Compatibility Wizard over the first but simple method is that you can try the game in the different modes (Windows 98, NT, etc.) without leaving the Wizard. In other words, you try running the game in the different modes within the Wizard until you find one that works or works best. If and when you find the best mode, save the setting and exit the Wizard. The game should run from now on like it ran while you were inside the Wizard.

    I don't have Vista so I don't know the particulars of it but you can change compatibility modes in Vista too. However, for a game that old sometimes they don't work in Vista no matter what but it doesn't hurt to try.
     
  5. willo51100

    willo51100 TS Rookie Topic Starter

    Ok I tried changing the compatibility mode on the computer and now I don't have the directX problem t the game will still not run because there seems to be a problem with comi.exe and the game just closes up...
     
  6. willo51100

    willo51100 TS Rookie Topic Starter

    the error message is "unable to load 'resource\font0.nut'"
    And by the way comi stands for curse of monkey island!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.