DirectX Problem

By XemnasD
Sep 12, 2009
Topic Status:
Not open for further replies.
  1. When i try to install Need for speed most wanted on my computer i just get a message that i need at least DirectX 9.0c or above.
    I have alredy installed the newest version of DirectX and i still get the same wrong message.
    I have read at some other thread that if i want to uninstall DirectX i will need a CD which i dont have and did neither get when i bought the computer.
    The specifications of my computer can you see at my profile.
    I think its wierd that i still can run Left 4 Dead perfectly fine which also demand the same version of DirectX.

    Thanks in advance.
    //Xemnas
  2. Kcircyrd

    Kcircyrd Newcomer, in training Posts: 316

    Check at www.Microsoft.com for the latest free download of DirectX 9.0c, version 9.27.1734. Ours if from March 2009. It is a large file but downloads and installs easily.
    It should write over the top of whatever version you have.
  3. XemnasD

    XemnasD Newcomer, in training Topic Starter

    Srry it didn´t work, i have already tried to install a newer version of DirectX.
  4. jassinlive

    jassinlive Newcomer, in training

    try install some of the old, like Direct X 9 from the website. Some older games aren't compatible with Direct X 10
  5. XemnasD

    XemnasD Newcomer, in training Topic Starter

    I did install DirectX 10 which i found out only works on Windows Vista and probably on Windows 7 so i uninstalled DirectX and installed DirectX 9 but i still had the same problem.
    But i did manage to find a solution. I opened the CD and copied the whole game to my desktop. Then i could change the requirements for the game to be installed. You open the file autorun.cfg under the folder autorun with notepad. It will look something like this:

    Registry=EA GAMES\Need for Speed™ Most Wanted
    Executable=speed.exe
    AppName=Need for Speed™ Most Wanted
    ProductGuiID={ADE91A13-434D-4229-00BC-182BAD607303}
    Icon=NFSMW_icon.ico
    EReg=1
    TechSupport=1
    AutoSort=1
    Demo=0
    RTPatch=1
    RTPatchCDID=NA
    DirectXVersion=9.0c
    ^
    ^
    ^
    Then you change this to:
    DirectXVersion=0
    Then it worked. (For me)
    If this doesnt work you could try to run the game as in some other windows Operating System. You right klick the AutoRun.exe file go down to properties and from there you should be able to do the rest yourself.

    Thankyou for your help
    //Xemnas
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.