TechSpot

"DNS lookup failed" error message while using Google Chrome

By kryan
Jun 23, 2011
Post New Reply
  1. Hi everyone.

    I've been getting the "DNS lookup failed" error message constantly while using Google Chrome. TCP/IPv4 settings for IP address and DNS server are on automatic as per my ISP's instructions. And Chrome is already listed as an exception in my Windows firewall. After talking with my ISP they insist that the problem is on my side, probably the firewall.

    I tried disabling the firewall and using Google's public DNS. This reduced the frequency of the errors, but doesn't get rid of them completely.

    Any suggestions would be appreciated.

    Thanks in advance.
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    re-enable the firewall
    connect to the router/modem per usual
    get a command prompt (start->run->cmd) and enter
    ipconfig /all >myTCP.txt
    now copy the entire contents of myTCP.txt and
    a) paste into your follow-up OR
    b) attach that file itself
     
  3. kryan

    kryan TS Rookie Topic Starter Posts: 65

    jobeard, thanks for the response. File is attached.
     

    Attached Files:

  4. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    [1] the system address and the gateway are in the same subnet which is correct.

    the DHCP address [2] looks wrong and
    the DNS addresses [3] are those of Google's DNS and should work - -
    but for now, try letting the DHCP set these automatically
    instead of your manual setup.

    further down we see
    which says IPv6 is enabled on your system - - disable IPV6,
    Google for Disable IPv6 and follow the instructions for your system {XP, Vista, Win7} - - be sure to reboot.
     
  5. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Okay, DNS is set back to automatic and IPv6 has been disabled.
     
  6. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    what happens when you try ping google.com ?
     
  7. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Pinging google.com [74.125.229.116] with 32 bytes of data:

    Reply from 74.125.229.116: bytes=32 time=146ms TTL=56

    Reply from 74.125.229.116: bytes=32 time=147ms TTL=56

    Reply from 74.125.229.116: bytes=32 time=142ms TTL=56

    Reply from 74.125.229.116: bytes=32 time=177ms TTL=56



    Ping statistics for 74.125.229.116:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    Approximate round trip times in milli-seconds:

    Minimum = 142ms, Maximum = 177ms, Average = 153ms
     
  8. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    wonderful - - that shows your system has resolved google.com -> ip address = 74.125.229.11674.125.229.116 and you can ping it

    this should also enable your browser access to http: // google.com/

    please report if that is not the case.


    *IF* you have browser access to google.com, you can now go back and put
    the 8.8.8.8 & 8.8.4.4 addresses into your tcp settings,
    [ ie: that was a good idea to start with, but needed to ensure your ISP and you could cooperate :) ]

    disconnect from your modem/router for at least 30 seconds, reconnect, wait another 30 seconds and then launch the browser and reverify access to google.com
     
  9. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Seems like disabling IPv6 is working for now. I have access to google.com and the error hasn't occurred since. Changed the DNS back to google's and I still have access.
     
  10. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    that's what I expected - - well done :)

    create a new System Restore Point and enjoy your Internet Surfing . . .
     
  11. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Looks like the problem has returned again. Yesterday, after applying the changes you suggested, my internet worked flawlessly. But when I started my PC this morning, the error appears, though not as frequently as before.

    Some additional information if it might help. I'm using a Dell Inspiron 1525 running Windows Vista Home Premium. I'm plugged directly into the modem when I use the internet. When I shut down I unplug the ethernet cable from the laptop.
     
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    make sure you disabled IPv6 via regedit, unchecking [ ] IPv6 Protocol in the TCP settings is good only during the existing login session. To permanently disable, the regedit solution is necessary.
     
  13. kryan

    kryan TS Rookie Topic Starter Posts: 65

    I used Microsoft "Fix It" to disable IPv6 the first time. When I follow the instructions to disable it via regedit, I see the appropriate entries and values already there.

    EDIT:
    Just to elaborate, in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters, DisabledComponents is set to 0xffffffff
     
  14. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    hmm; interesting.

    I recommend you power off
    1. shutdown your system,
    2. power off any router connnected to your modem,
    3. and your ISP Modem as well
    wait at least 30 seconds, and restart them like this
    1. power ON the modem; wait one mintue for it to stablize
    2. power on the router and wait 30 seconds
    3. now restart your system

    when you get here, retrun that IPCONFIG /ALL >myTCP2.txt
    and attach it to your follow-up . . . .
     
  15. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Results attached.
     

    Attached Files:

  16. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    good; get the command prompt again and
    1. ipconfig /flushdns
    2. net stop "dns client" #keep these quotes
    3. net start "dns client"

    you should be able to ping google.com and access google with the browser.

    if you fail, please quote the specific URL or domain name attempted . . .
     
  17. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Ran the above successfully as administrator but still having trouble. Pinging google doesn't give consistent results. Sometimes the request completes successfully, sometimes there's packet loss, and sometimes it can't find the host at all.
     
  18. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    run these
    1. nslookup google.com. >lookup.log #note trailing period after the .com
    2. tracert google.com >tracert.log #and no period after this one
    attach both files please

    be prepared to regress to using only the DHCP provided DNS addresses instead of the manual 8.8.8.8 . . .
     
  19. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Okay. See attached.
     

    Attached Files:

  20. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    my my; you cant reach the DNS at 8.8.8.8
    DNS request timed out.
    timeout was 2 seconds.
    Server: UnKnown
    Address: 8.8.8.8

    DNS request timed out.
    timeout was 2 seconds.
    DNS request timed out.
    timeout was 2 seconds.
    nix the manual DNS settings in the TCP and set both your IP address & DNS addresses to be Automatic and save.

    disconnect the system from the router/modem; wait 30sec and then recable.
    wait another 30sec and retry ping google.com
     
  21. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Here are the results after a couple of tries:

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Users\Client>ping google.com

    Pinging google.com [74.125.229.116] with 32 bytes of data:
    Reply from 74.125.229.116: bytes=32 time=57ms TTL=56
    Reply from 74.125.229.116: bytes=32 time=57ms TTL=56
    Request timed out.
    Reply from 74.125.229.116: bytes=32 time=55ms TTL=56

    Ping statistics for 74.125.229.116:
    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 55ms, Maximum = 57ms, Average = 56ms

    C:\Users\Client>ping google.com

    Pinging google.com [74.125.229.116] with 32 bytes of data:
    Reply from 190.213.84.86: Destination host unreachable.
    Request timed out.
    Reply from 190.213.84.86: Destination host unreachable.
    Reply from 190.213.84.86: Destination host unreachable.

    Ping statistics for 74.125.229.116:
    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

    C:\Users\Client>ping google.com

    Pinging google.com [74.125.229.116] with 32 bytes of data:
    Reply from 190.213.84.86: Destination host unreachable.
    Reply from 190.213.84.86: Destination host unreachable.
    Reply from 74.125.229.116: bytes=32 time=2064ms TTL=56
    Reply from 74.125.229.116: bytes=32 time=56ms TTL=56

    Ping statistics for 74.125.229.116:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 56ms, Maximum = 2064ms, Average = 1060ms
     
  22. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    this clearly points to an reliable path to google, not only very bad timings, but also total disconnect.

    you can monitor this easier with ping -n 200 google.com which will take 200 samples before it quits, but let's discover where the network is failing by running
    tracert google.com
     
  23. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Users\Client>tracert google.com

    Tracing route to google.com [74.125.229.114]
    over a maximum of 30 hops:

    1 * * * Request timed out.
    2 * * * Request timed out.
    3 8 ms 9 ms 8 ms te-3-2.tt.aggr01.columbustrinidad.com [200.1.111
    .30]
    4 10 ms 9 ms 11 ms xe-0-0-0.tt.edge01.columbustrinidad.com [200.1.1
    11.20]
    5 57 ms 57 ms 59 ms 63.245.3.41
    6 * 62 ms 60 ms 63.245.3.34
    7 Client-PC.flowtrinidad.com [190.213.84.86] reports: Destination host unrea
    chable.

    Trace complete.
     
  24. jobeard

    jobeard TS Ambassador Posts: 13,446   +324

    quite nasty.
    Item one is YOU,
    Item two is your ISP gateway
    Item 7 looks to be a system at 190.213.84.86 that is not even running

    but in post#15 your system IP was shown as 190.213.84.86 WHAT GIVES?
    You can't have 7 nops between yourself and yourself, so when this was run
    your IP address was clearly no longer 190.213.84.86.


    reboot the system and then run ALL of these and post all the files
    1. ipconfig /all >currentTCP.txt
    2. nslookup google.com. >lookup2.log
    3. tracert google.com >path2google.log
    attach all the files, currentTCP.txt, lookup2.log, path2google.log
     
  25. kryan

    kryan TS Rookie Topic Starter Posts: 65

    Okay, done. Results attached.
     

    Attached Files:



Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.