Doom3 wrong DLL API version

By dustin_ds3000
Mar 20, 2008
Topic Status:
Not open for further replies.
  1. DOOM 1.3.1302 win-x86 May 12 2005 10:40:52
    2133 MHz AMD CPU with MMX & 3DNow! & SSE
    1024 MB System Memory
    128 MB Video Memory
    Winsock Initialized
    Found interface: {D3A19E54-D4D3-4FA3-9F9D-D6B3F055C378} SiS 900 PCI Fast Ethernet Adapter #2 - 216.163.4.152/255.255.255.0
    Sys_InitNetworking: adding loopback interface
    doom using MMX & SSE for SIMD processing
    enabled Flush-To-Zero mode
    ------ Initializing File System ------
    Loaded pk4 C:\Program Files\Doom 3\base\game00.pk4 with checksum 0x29cdb978
    Loaded pk4 C:\Program Files\Doom 3\base\game01.pk4 with checksum 0x51c6981f
    Loaded pk4 C:\Program Files\Doom 3\base\game02.pk4 with checksum 0xf3ec6f7
    Loaded pk4 C:\Program Files\Doom 3\base\game03.pk4 with checksum 0x5d4230ea
    Loaded pk4 C:\Program Files\Doom 3\base\pak000.pk4 with checksum 0x28d208f1
    Loaded pk4 C:\Program Files\Doom 3\base\pak001.pk4 with checksum 0x40244be0
    Loaded pk4 C:\Program Files\Doom 3\base\pak002.pk4 with checksum 0xc51ecdcd
    Loaded pk4 C:\Program Files\Doom 3\base\pak003.pk4 with checksum 0xcd79d028
    Loaded pk4 C:\Program Files\Doom 3\base\pak004.pk4 with checksum 0x765e4f8b
    Loaded pk4 C:\Program Files\Doom 3\base\pak005.pk4 with checksum 0x8ffc3621
    Loaded pk4 C:\Program Files\Doom 3\base\pak006.pk4 with checksum 0x95b65ab
    Loaded pk4 C:\Program Files\Doom 3\base\pak007.pk4 with checksum 0x666bdb3c
    Loaded pk4 C:\Program Files\Doom 3\base\pak008.pk4 with checksum 0x23ae5993
    Current search path:
    C:\Program Files\Doom 3/base
    C:\Program Files\Doom 3\base\pak008.pk4 (3 files)
    C:\Program Files\Doom 3\base\pak007.pk4 (38 files)
    C:\Program Files\Doom 3\base\pak006.pk4 (48 files)
    C:\Program Files\Doom 3\base\pak005.pk4 (63 files)
    C:\Program Files\Doom 3\base\pak004.pk4 (5137 files)
    C:\Program Files\Doom 3\base\pak003.pk4 (4676 files)
    C:\Program Files\Doom 3\base\pak002.pk4 (6120 files)
    C:\Program Files\Doom 3\base\pak001.pk4 (8972 files)
    C:\Program Files\Doom 3\base\pak000.pk4 (2698 files)
    C:\Program Files\Doom 3\base\game03.pk4 (2 files)
    C:\Program Files\Doom 3\base\game02.pk4 (2 files)
    C:\Program Files\Doom 3\base\game01.pk4 (2 files)
    C:\Program Files\Doom 3\base\game00.pk4 (2 files)
    game DLL: 0x0 in pak: 0x0
    Addon pk4s:
    file system initialized.
    --------------------------------------
    ----- Initializing Decls -----
    ------------------------------
    ------- Initializing renderSystem --------
    using ARB renderSystem
    renderSystem initialized.
    --------------------------------------
    5206 strings read from strings/english.lang
    Couldn't open journal files
    execing editor.cfg
    execing default.cfg
    execing DoomConfig.cfg
    couldn't exec autoexec.cfg
    5206 strings read from strings/english.lang
    ----- Initializing Sound System ------
    sound system initialized.
    --------------------------------------
    ----- R_InitOpenGL -----
    Initializing OpenGL subsystem
    ...registered window class
    ...registered fake window class
    ...initializing QGL
    ...calling LoadLibrary( 'opengl32' ): succeeded
    ...calling CDS: ok
    ...created window @ 0,0 (800x600)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...PIXELFORMAT 10 selected
    ...creating GL context: succeeded
    ...making context current: succeeded

    ------- Input Initialization -------
    Initializing DirectInput...
    mouse: DirectInput initialized.
    keyboard: DirectInput initialized.
    ------------------------------------
    sound: STEREO
    ...using GL_ARB_multitexture
    ...using GL_ARB_texture_env_combine
    ...using GL_ARB_texture_cube_map
    ...using GL_ARB_texture_env_dot3
    ...using GL_ARB_texture_env_add
    X..GL_ARB_texture_non_power_of_two not found
    ...using GL_ARB_texture_compression
    ...using GL_EXT_texture_compression_s3tc
    ...using GL_EXT_texture_filter_anisotropic
    maxTextureAnisotropy: 8.000000
    ...using GL_1.4_texture_lod_bias
    ...using GL_EXT_shared_texture_palette
    ...using GL_EXT_texture3D
    ...using GL_EXT_stencil_wrap
    ...using GL_NV_register_combiners
    ...using GL_EXT_stencil_two_side
    X..GL_ATI_fragment_shader not found
    X..GL_ATI_text_fragment_shader not found
    ...using GL_ARB_vertex_buffer_object
    ...using GL_ARB_vertex_program
    ...using GL_ARB_fragment_program
    X..EXT_depth_bounds_test not found
    ---------- R_NV20_Init ----------
    ---------------------------------
    ----------- R200_Init -----------
    Not available.
    ---------- R_ARB2_Init ----------
    Available.
    ---------------------------------
    ----- R_ReloadARBPrograms -----
    glprogs/test.vfp
    glprogs/test.vfp
    glprogs/interaction.vfp
    glprogs/interaction.vfp
    glprogs/bumpyEnvironment.vfp
    glprogs/bumpyEnvironment.vfp
    glprogs/ambientLight.vfp
    glprogs/ambientLight.vfp
    glprogs/shadow.vp
    glprogs/R200_interaction.vp
    glprogs/nv20_bumpAndLight.vp
    glprogs/nv20_diffuseColor.vp
    glprogs/nv20_specularColor.vp
    glprogs/nv20_diffuseAndSpecularColor.vp
    glprogs/environment.vfp
    glprogs/environment.vfp
    glprogs/arbVP_glasswarp.txt: File not found
    glprogs/arbFP_glasswarp.txt: File not found
    -------------------------------
    using ARB_vertex_buffer_object memory
    using ARB2 renderSystem
    found DLL in pak file: C:\Program Files\Doom 3\base\game03.pk4/gamex86.dll
    copy gamex86.dll to C:\Program Files\Doom 3\base\gamex86.dll
    3 22 800 600
    Regenerated world, staticAllocCount = 0.
    Shutting down sound hardware
    idRenderSystem::Shutdown()
    Shutting down OpenGL subsystem
    ...wglMakeCurrent( NULL, NULL ): success
    ...deleting GL context: success
    ...releasing DC: success
    ...destroying window
    ...shutting down QGL
    ...unloading OpenGL DLL
    wrong game DLL API version

    it was working fine then i updated the game with the DOOM3-1.3.1 patch and this happend
  2. mopar man

    mopar man TechSpot Ambassador Posts: 1,492

    Maybe try reinstalling?
  3. mailpup

    mailpup TS Special Forces Posts: 8,277   +178

    Also, if you do reinstall, try downloading a fresh copy of the patch from another server in case the file was corrupted in some way.
  4. Acclamator

    Acclamator Newcomer, in training Posts: 295

    Do you have the latest version of DirectX?
  5. dustin_ds3000

    dustin_ds3000 TechSpot Chancellor Topic Starter Posts: 1,126

    im running windows vista
  6. mopar man

    mopar man TechSpot Ambassador Posts: 1,492

    Maybe you should try running it in compatibility mode.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.