drive treated as file, can't access c:\ from my computer

By nquery
Mar 22, 2007
Topic Status:
Not open for further replies.
  1. this is a such a strange problem, i can't even think of the proper search string to use

    after installing AVG virus scanner, (maybe this is unrelated, but this is when it happened) and scanning my system, and getting rid of a number of "threats", when i open My Computer, and try to double click on any of the drive icons, i get an "Open with" / "Choose the program you want to use to open this file: C:\" dialogue box. it treats my drives as if they were unknown file types!! so i can't access my drives with double click.

    when i right click on the drive icon, where "Open" and "Explore" used to be, now all i see is gibberish. the rest of the context menu is fine, and i can still access everything (e.g. right click/properties will bring up the properties of the drive). also, if i type "c:\" into the address bar, i can access the drive just fine, but double click on the drive icon doesn't work. accessing the drives from the "windows explorer" side panel works fine also.

    i've had a lot of trouble finding the registry keys responsible for the drive icons in my computer. i don't know if that may be a possible solution, to redirect the icon paths to their respective drives.

    anyone else run into something like this and fixed it? it's really weird, usually i find fixes to my problems through research, but i'm stumped. hope someone can help.

    thanks
  2. Striker840

    Striker840 Newcomer, in training Posts: 16

    This is a new one for me, at least you can still access the drive thru explorer.
    Hopefully some of the brain's on this site can help ya out.
  3. nquery

    nquery Newcomer, in training Topic Starter

  4. inferno82

    inferno82 Newcomer, in training

    unable to access hard drive

    hey nquery !

    dude this problem sucks ***, its really annoying, i posted to so many threads but no one came out with a solution. I however was able to solve the problem and restore drive associations :cool: . This is not a malware/virus problem so no need to do thorough scanning.

    Well the solution is a little orthodox but that is the only way i could get that 'open' and 'explore' gibberish to disappear from the right click menu and restore associations.

    This is what you need to do. You would need to delete a file called autorun.inf from all your drives C: D: so on and so fourth. The problem is if u search for this file it will not appear. So this is what i did. I browsed my pc using my cell phone (K 700I) with a bluetooth device attached to my pc. Once your cell phone established connection with ur pc's bluetooth just browse to C: and delete autorun.inf. Deleting this file will cause that gibberish to disappear. and will show the "explore" option right at the begining of the menu and followed by "open"

    Then navigate to this key is system registry: HKEY_CLASSES_ROOT\Drive

    Click on the Drive folder in the right pane this is what it should say

    Name TYPE DATA
    (Default) REG_SZ none




    After that expand the Drive folder and click on 'Shell'. In the right pane it should say the same as given above. If it is not then modify it according to the above info and restart your system.

    Expand "Shell" and click on Find. This is what it should say

    NAME TYPE DATA
    (Default) REG_SZ (value not set)
    Supressionpolicy REG_DWORD 0*00000080 (128)


    Click on the "open" folder underneath the "find " folder. This is what is should say

    NAME TYPE DATA
    (Default) REG_SZ (value not set)


    Hope this helps bro !
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.