TechSpot

Dual boot system will not boot Ubuntu

By lopdog
Dec 27, 2008
Topic Status:
Not open for further replies.
  1. Hi!

    Recently I installed Vista and Ubuntu 8.10 on a 320 gb hdd, following a guide found at http://apcmag.com/how_to_dualboot_vista_with_linux_vista_installed_first.htm?page=1.

    First I installed Vista, leaving 20 gb unassigned space at the end of the hdd. Then I installed Ubuntu 8.10 from the live-cd to the unassigned space.

    I wanted Vista to load as default, so I followed step 4 from the guide, and now I have two boot-options (Vista and NeoGrub Bootloader), but when I choose the NeoGrub Bootloader I get an error msg saying that Vista can't load.

    Does anyone know how to set up the boot options? I want the ability to choose between Vista and Ubuntu, and Vista to load as default after about 5 seconds.

    Thanks
  2. BorisandBailey

    BorisandBailey TS Enthusiast Posts: 206

    There's actually an easy workaround for this if you're willing to let Grub be the default boot loader, that is, when your computer turns on, it goes straight into Grub and about four or so items are on the menu, including about three for Ubuntu and one for Windows. The idea is that after a period of so many seconds, it automatically goes into Windows. I found this at the How-To Geek site.

    http://www.howtogeek.com/howto/ubuntu/set-windows-as-default-os-when-dual-booting-ubuntu/

    When you install a dual-boot of Ubuntu, one of the frustrating things that you'll immediately notice is that Ubuntu is now set as the default operating system in the Grub loader. There's an easy way to switch back to using Windows as the default.

    To make this change, you'll first have to boot into Ubuntu, and then run the following command:

    sudo gedit /boot/grub/menu.lst

    Find this section of the file:

    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not change this entry to 'saved' or your
    # array will desync and will not let you boot your system.
    default 0

    The important line is the last one. You will need to change that number 0 to match the Windows boot section. Typically it's always going to be 4 on a default dual-boot configuration. Change this value to 4, and then save and reboot your machine. You should go into Windows instead of Ubuntu automatically.

    Note: The blocks at the bottom of the file match the items in the menu. You can change this value to match whichever item you want as default, just remember that numbering starts at 0.
  3. lopdog

    lopdog TS Maniac Topic Starter Posts: 378

    Thanks, that looks easy, but right now I'm unable to boot into Ubuntu, because I use the Vista bootloader. How can I reinstall the grub bootloader, from within Vista or maybe from the Ubuntu Live CD
  4. BorisandBailey

    BorisandBailey TS Enthusiast Posts: 206

    I don't have a satisfactory answer for that, but there is a free WinGrub software that is supposed to let you dual-boot from Windows. I tried it but I couldn't get it to recognize Ubuntu, possibly because I had two hard drives--one for Windows Media Center and one for Ubuntu, and those were IDE drives. Windows Media Center had a different boot setup (I forget what it's called; it doesn't use the basic boot setup) that made it impossible to allow Linux to be seen, and I've read Vista has the same boot setup but perhaps SATA drives get around that. These days I use Windows XP and Ubuntu on SATA drives. First I installed Windows XP, second I installed Ubuntu, and the Grub loader automatically installed giving me the two options.

    My guess is that your Vista boot loader doesn't see the Ubuntu partition, probably because Microsoft isn't programmed to allow other operating systems to be seen. If you installed Ubuntu after you installed Windows, my guess is that Grub should have made itself the default boot loader. Did you make sure the partition was not NTFS or any other designation? If it was a blank partition, then Ubuntu would do the rest.

    My method would be to let the Ubuntu CD erase the partition and then re-install Ubuntu, BUT, before you try that, i would see if there's a less destructive and easier way to get Ubuntu to be seen. My way is definitely the hard way.

    I'll have to check on that boot loader that the Windows Media Center operating system used and to double-check to see if Vista uses it now. It was very unfriendly towards Linux. Maybe there's a member who can clear it up. I'm not sure about this.
  5. lopdog

    lopdog TS Maniac Topic Starter Posts: 378

    I did it the hard way, I deleted the entire linux partition from Vista, and made a clean Ubuntu install. Vista didn't load after that, I had to use the Vista DVD to repair (some error in the bootsector, i suppose). After that it loaded normally.
    Then I followed the tips from the site you gave me. Works fine and boots Vista after 5 seconds, but every time I turn on the computer, the grub bootloader stops after the first text line (no error message). I have to turn of the computer using the power switch, and when I turn it on again everything works. But it's very annoying.
  6. BorisandBailey

    BorisandBailey TS Enthusiast Posts: 206

    That does sound annoying! My first guess is that something needs to be fixed in Ubuntu's menu.lst file, which is the file responsible for loading grub and giving you the choices of which operating system to use. There is a users group at http://ubuntuforums.org that often has people who run into similar problems. I'll take a look over there to see what posts they may have.
  7. ebrider13

    ebrider13 TS Rookie Posts: 16

    ubuntu is junk :p
  8. BorisandBailey

    BorisandBailey TS Enthusiast Posts: 206

    Oh, but it is such sweet junk! I've been using it for a year and I'm a very happy camper!
  9. lopdog

    lopdog TS Maniac Topic Starter Posts: 378

    I tried to fix this the hard way, again :(
    I removed the ubuntu partition, reinstalled the Vista bootloader using the Vista DVD, and reinstalled Ubuntu. Then again I edited the /boot/grub/menu.lst file, changing only two numbers (I set default timeout to 5 sec, and default OS to 4).
    But the bootloader still stops, and I have to do a hard restart to get it to load any OS. I'm tempted to just remove Ubuntu, even if it's sweet.
  10. BorisandBailey

    BorisandBailey TS Enthusiast Posts: 206

    There's something you might double-check...When you do get the grub menu on the screen (mine looks like a black screen with white letters), how many selections are there? Mine has four: the first one is Ubuntu, the second and third selections are Ubuntu related, then the fourth selection is Windows. That's why my default OS would be set to 4. If I had three selections and Windows was the third one, I'd set the default to 3. Sounds dumb, but I've known myself to make unconscious mistakes like setting a default to something that didn't exist.

    Something else to try: Make the default OS to number 1 and see if the grub menu comes up.

    I don't blame you for being frustrated. I gave up on my Gateway computer that had Windows Media Center XP. No matter what changes I made to menu.lst, it just wouldn't take. I finally built my own computer, used SATA connections, and Windows Home XP.
  11. lopdog

    lopdog TS Maniac Topic Starter Posts: 378

    I double-checked the entries. I have 4 entries too, three related to Ubuntu and the last is Windows, but there is a line before the windows option that says "Other operating systems". If I set the default option to 3, that line gets selected (the bootloader starts counting at 0).
    I've also tried setting the default to 0, same problem.

    But it seems to be a problem with Vista, because when I use Ubuntu, there's no problem after rebooting/turning of the computer, but if the last OS I used was Vista, the bootloader doesn't work.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.