DVDs won't play

By shooshi
Mar 1, 2009
Topic Status:
Not open for further replies.
  1. Hi,

    I have an Acer Aspire 5920g which uptil today was playing my dvd's fine.
    When I tired getting them to read today, windows media player said that there was a copyright disclaimer issue between my dvd drive, video card...and decoder

    And this was supposed to be a regional issue (I have dvd reg killer on)
    It told me and is still telling me that windows media player thought that I was set to region 1

    I went to my computer (I have windows vista btw) and checked my dvd drive, when I found a surprise.

    I had 2 drives, one cd and one dvd (the cd one is new, in all my time with this laptop I had never seen it) In any case, I checked all the drives, everything was region 2, just like the dvd I had tried to put it.

    I then tried to see if disabling the "fake" cd drive would help, with no success

    Then I proceeded by downloading other media players, everything from real to vlc

    VLC manages to read the dvd, but the image is a big lot of fuzz and very staticky.

    I then tried other dvd's..
    for all other region 2 ones I tried, I had the same problem

    and for a region free dvd, the computer isnt even recognising it.

    Anyway, thankyou for reading this and I hope you'll be able to help :)

    I have been reading tips and suggestions from this site for a long while, first time I've ever had to post though!

    shooshi
  2. shooshi

    shooshi Newcomer, in training Topic Starter

    Update:

    I have uninstalled deamon tools which had created the fake drivwe.

    it hasn't changed the situation though, I still can't play any of my dvd's due to the same reason, any suggestions/help?

    I was thinking of a rollback to whhen I installed deamon tools (sometime last week) because I know for sure that I was reading dvd's until at least 2 weeks ago (which is when i last tried)

    good idea?
  3. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    you can try a system restore (as you say) or simply try removing the upper and lower filters for your CD/DVD devices see this MS KB

    Note: Once you've removed these current filters (which can interfere with the DVD driver) you may need to reinstall all your media players / applications which access / use the DVD
  4. shooshi

    shooshi Newcomer, in training Topic Starter

    hmm..

    Yep, I meant..rollback?

    Anyway, thankyou for the advice, I found the things and have deleted them, on my next restart I'll know if it works or not :)
  5. shooshi

    shooshi Newcomer, in training Topic Starter

    another update

    Ok I did the whole deleting of upper and lower things, went to media player after a restart and it asked me to change zones to read the dvd, and it did say I was on zone 1, so that is good news.


    However, I didn't want to use up any of my changes available...so I reinstalled dvd region killer...to find I have the same problem all over again.

    Am in the process of uninstalling all media players now, will redo that registry change and then reinstall media player to see what happens :)
  6. shooshi

    shooshi Newcomer, in training Topic Starter

    It works!

    however..i did have to use up one of my chances to change zone

    can i still use region dvd killer on my computer, or will that re muck things up?

    for instance if i want to watch other films which aren't region 2?
  7. fimbles

    fimbles TechSpot Evangelist Posts: 1,227   +118

    Vlc media player will play any dvd from any region. Im not sure why you are having picture issues. But a fresh reinstall of vlc would probly be your best option.

    You can try dvd killer again but if it does muck things up, you will have to reapeat this whole process again :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.