E_machine Monitor E15TR trouble

By Sharla
Nov 12, 2006
  1. Can anyone tell why Icannot get this monitor to show a screen. I have tried it on several computers and all I get is a power light blinking, no screen or startup display. I have no manuels on this display or history because I got it from a neighbor who tells me it worked fine before.
    Would appreciate anyones help. Sharla
  2. Rik

    Rik Banned Posts: 3,814

    The only thing you can do is have a look to see if any of the pins in the plug are bent!!!! If any are, unplug the monitor from the mains then carefully straighten the pin(s) out!!!!

    That's about the only thing you can do without opening the monitor up, which i DO NOT recommend as there are EXTREMELY dangerous voltages inside!!!!
  3. Sharla

    Sharla TS Rookie Topic Starter


    I found a missing pin. Have no idea where it could be. Thanks for the info.
  4. Rik

    Rik Banned Posts: 3,814

    How many pins are in the plug???? They are not usually all there anyway!!!!
  5. klyn

    klyn TS Rookie

    There is a pin missing from my E15Tr. Can we pull a pin from another monitor plug and push it into my plug? Or will that not work?
  6. klyn

    klyn TS Rookie


    I am pretty sure I used to have all 15 pins. I'm missing pin #5
  7. gavinseabrook

    gavinseabrook TS Rookie Posts: 320

    That could be a problem. Another problem is that Emachine monitors suck anyway. In that fact all e-machine products suck. Monitor tubes break, CPU power supplies go out, then the hard drive. I would just get a new one. That or pay a repair shop.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...