Editing GRUB menu

By coltie
Jul 30, 2011
Post New Reply
  1. Hi,
    I'll preface this by explaining that I'm a novice, hobby builder with practically zero understanding of Linux. In fact the problem described below occurred while I was installing Ubuntu in an effort to learn about Linux based OSs.

    My system has Windows 7 Home 64 bit installed on a WD internal hard drive and I added a second internal drive (Seagate) with the intention of installing Ubuntu thereby having a dedicated drive for each OS.

    I attempted to install Ubuntu 10.10 from a dvd on the blank Seagate drive but musn't have disabled the WD drive in the bios because I ended up with both OSs installed on the WD drive and a GRUB boot menu now appears immediately after my mb splash screen. Both OSs work perfectly and I'm content with the result except if I disconnect the Seagate drive I get a GRUB error and am unable to boot either OS.

    What I'm wanting to do is remove the Seagate drive from the GRUB boot menu so that I can install it in another machine. I'm also novice in command-line protocol so will need to be walked through the procedure with my hand being held. 8)

    Included below are screen shots of the boot menu, edit page and error page. If anyone can assist me it would be greatly appreciated.

    Attached Files:

  2. steeve

    steeve Newcomer, in training Posts: 192

    seems strange - if both os are on the wd drive, grub should be unconcerned about the seagate drive

    in the linux system, partition manager, is ubuntu definitely shown as installed on the wd drive?

    in the error msg, the missing drive is b28089...and the grub menu shows grub is looking for linux on that same drive

    anyway well done for having two working oses!

    also you need to establish clearly which drive is hd1
  3. coltie

    coltie Newcomer, in training Topic Starter

    Hi Steve. thanks for the help.
    It turns out I did manage to install Ubuntu on the Seagate.
    Sata 1 is the dvd
    Sata 2 is WD
    Sata 3 is the Seagate

    Boot order in bios is WD, Seagate, dvd
    I tried changing it to Seagate first and no boot, no error message just a suspended boot screen.
    When I set it up this way I had the notion that I'd be able to disable one of the drives in the bios and boot with the other.
    Here's the hard disk info from Ubuntu..

    Attached Files:

  4. Leeky

    Leeky TechSpot Evangelist Posts: 4,378   +97

    As you have said, it is correctly installed, though given the size of your disk you'd be much better creating separate partitions for your Linux install.

    The reason the WD is the boot device is that is the disk containing the original MBR records for Windows, and therefore now contains (as it overwrites the Windows record for) GRUB to load the boot choice menu. This is normal, and nothing for you to worry about.
  5. coltie

    coltie Newcomer, in training Topic Starter

    Thankyou Leeky for the reply and helpful link.
  6. steeve

    steeve Newcomer, in training Posts: 192

    coltie, seems like you have a good set up.

    for your own information, it's good to have a clear picture of the contents of your disks and partitions. in the terminal, a useful command is
    Code:
    fdisk -l 
    which lists the partition tables of your disks
    also,
    Code:
    nano /etc/fstab
    will open the fstab file (don't edit it yet!) which shows similar info.

    http://www.tuxfiles.org/linuxhelp/fstab.html
  7. coltie

    coltie Newcomer, in training Topic Starter

    Thanks to you as well steeve, I've learned plenty this weekend.
    Enjoying the Ubuntu experience more every day as well.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.