TechSpot

Error 1003 on XP sp3

By Lord Kamina
Oct 6, 2008
  1. I've been getting the 1003/reboot for a while now and I'm looking for help on fixing it...

    From what I gather, it probably has to do with video, since it happens when I try to open .3gp files or when I try previewing movies on Subtitleworkshop (There might be more but I haven't spotted them)

    My video drivers are not current, I know that's a very likely cause for the problem but I really don't want to update them until I'm sure it's that... Could somebody help me with this?

    Here's some minidumps...


    And the EventViewer report:

    Date: 10/06/08 Source: System Error
    Time: 17:44:49 Category: (102)
    Type: Error Event ID: 1003
    User: N/A
    Computer: ENKIDU

    0000: 53 79 73 74 65 6d 20 45 System E
    0008: 72 72 6f 72 20 20 45 72 rror Er
    0010: 72 6f 72 20 63 6f 64 65 ror code
    0018: 20 31 30 30 30 30 30 37 1000007
    0020: 66 20 20 50 61 72 61 6d f Param
    0028: 65 74 65 72 73 20 30 30 eters 00
    0030: 30 30 30 30 30 64 2c 20 00000d,
    0038: 30 30 30 30 30 30 30 30 00000000
    0040: 2c 20 30 30 30 30 30 30 , 000000
    0048: 30 30 2c 20 30 30 30 30 00, 0000
    0050: 30 30 30 30 0000
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Inside all 4 MiniDumps:
    cmuda.sys: CMedia AC97 Audio Device driver

    Well, it's your audio driver
    Please uninstall it fully
    Then update to the newest driver version (from your manufacture's support page)
     
  3. Lord Kamina

    Lord Kamina TS Rookie Topic Starter

    ... Go figure.
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Huh "Video" ! (you said)

    You silly billy you

    Let us know how it all goes :)
     
  5. Lord Kamina

    Lord Kamina TS Rookie Topic Starter

    I completely uninstalled the drivers (And something indeed appeared to be fishy because there was two different C-Media entries under Add/Remove, and they both claimed to uninstall the drivers and both rebooted the PC after uninstalling, I thought maybe I had two versions clashing or something) and then let Windows Update download them again.

    Aaaaand... Still not working.

    New dump...
     
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    1. Uninstall the drivers from Add/Remove programs in the Control Panel of Windows.
    2. Restart the computer.
    3. Run Driver Sweeper*, select the drivers that you have uninstalled and click Clean button.
    4. Install the new drivers.

    To download and install Driver Sweeper, please click HERE. (direct link)
    Save DriverSweeper_1.5.5-setup-[Guru3D.com].exe file on the hard disk.
    Run DriverSweeper_1.5.5-setup-[Guru3D.com].exe.

    Once all done
    I'd even locate cmuda.sys, rename it to old, then update the drivers again
     
  7. Lord Kamina

    Lord Kamina TS Rookie Topic Starter

    Hmm... Did exactly as you say, minus C-Media wasn't listed in DriverSweeper, but I searched the HD and the registry for cmuda and found nothing. (Also ran a Tuneup Registry cleaner)

    It's still not working. Going on a limb, I'm gonna try reinstalling DirectX.

    Oh by the way, I tried triggering the reboot while the driver was still uninstalled and the program basically gave me a "Cannot decode a stream, codec might be missing" error but it didn't reboot.
     
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    It resides here:
    c:\ windows\system32\drivers\cmuda.sys
    You could check for hidden and system files too, in your search
    It must exist to get an Error for it

    Actually it may be good to do the DirectX, I think it updates this file too
     
  9. Lord Kamina

    Lord Kamina TS Rookie Topic Starter

    I meant I checked it was completely gone before re-installing it and it was.
    I didn't get the error 'til I reinstalled the driver.
     
  10. Lord Kamina

    Lord Kamina TS Rookie Topic Starter

    Aaaand... It's ffdshow, after all.

    I tried rolling back to DX8.1 and the problem persisted, so I reinstalled DX9 and after uninstalling ffdshow, the problem is gone. (I had configured ffdshow not to run in the cases were the bug was activating for videos, but I never did it for the audio decoder...)

    So... I guess I'll have to submit the issue to whoever is developing ffdshow.
     
  11. Lord Kamina

    Lord Kamina TS Rookie Topic Starter

    So... I installed a different version of ffdshow and the problem is fixed for SubtitleWorkshop but it persists on .3gp files.

    Can you check this minidump and tell me if it's still cmuda.sys?
     
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Guess what
    There is another area of conflict with drivers
    And that is IRQ issues
    What this means, is that possibly one of you other installed Hardware items is using the same IRQ entry, and therefore causing a fault

    Have you installed any new addon hardware?
    If so, possible physically remove it, then bootup and test again

    Other than that it's still driver fault

    I just though of another possible issue, it could be corruption in Windows, or even cross-linked files (although I believe you would get a different Bugcheck code.
    You could try doing a CheckDisk on the drive too.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...