TechSpot

Error 1084 - can only use laptop in safe mode

By suzyuk
Aug 18, 2011
Post New Reply
  1. Hi

    For the past week or so my laptop has been randomly freezing during use and now it does it everytime it starts in Normal Mode just after the desktop appears.

    It will now only run in Safe Mode. I looked at the event viewer and found the following:

    DCOM got error "1084" attempting to start the service McNaiAnn with arguments "" in order to run the server:
    {DC7EF8E1-824F-4110-AB43-1604DA9B4F40}

    Any help I can get will be most gratefully received. I was going to attempt a full rebuild, but I can't find my Windows Vista disk.

    Thanks
    Suzy
  2. Route44

    Route44 TechSpot Ambassador Posts: 12,140   +29

    Hi Suzy. The fact that you can only boot into Safe Mode indicates that the issue is due to a bad driver (or two) or the possibility you are infected.

    1. Have you recently experienced any infections? Have you done a virus and malware scan?

    2. Do you get Blue Screens?

    3. Had you installed any new software or updated any software prior to your problems?
  3. suzyuk

    suzyuk TS Rookie Topic Starter

    Hi Route 44

    I do not get blue screens .. just a freeze, last week it would happen after I'd been using the machine for some time, now it is just after the icons have appeared on the desktop.

    I have McAfee on the laptop that I have on all the time. I have not done a full scan for a few months.

    I have recently installed the drivers for a new printer, but the laptop ran for a few weeks after that with no trouble.

    The only other trouble I have had is with Adobe Creative Suite CS3. I had this installed as my home copy of my work software as I'm a web designer and sometimes work from home. At the end of March the copy on my laptop became unregistered for no apparent reason and I have not been able to use it since then. I have tried reinstalling the software but it still won't work. I have now uninstalled it completely (I think!).

    The Windows Vista software automatically updates, and I have updated my iTunes software. Java asks for updates every couple of days and I usually say yes. I have also updated Notepad++ in the past couple of weeks.

    Thanks
    Suzy
  4. Route44

    Route44 TechSpot Ambassador Posts: 12,140   +29

    First, McAfee has a poor detection rating. My suggestion to you is is completely uninstall it (they may have a special Removal Tool = use it!) and download the free and excellent Avast antivirus after your issue is straightened out.

    Second, make sure your laptop vents are clear of dust. Heat will freeze/shut-down a system fast. Run it on a laptop cooler.

    Do this: Start > Run > EventVwr.msc > Okay Now look for any Yellow Triangles and Red X's and note what they flag.
  5. suzyuk

    suzyuk TS Rookie Topic Starter

    Like this:

    Log Name: Application
    Source: Microsoft-Windows-WMI
    Date: 19/08/2011 16:26:35
    Event ID: 10
    Task Category: None
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: Bernard
    Description:
    Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.
    Event Xml:
    <Event xmlns="link removed">
    <System>
    <Provider Name="Microsoft-Windows-WMI" Guid="{1edeee53-0afe-4609-b846-d8c0b2075b1f}" EventSourceName="WinMgmt" />
    <EventID Qualifiers="49152">10</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-08-19T15:26:35.000Z" />
    <EventRecordID>124259</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>Bernard</Computer>
    <Security />
    </System>
    <EventData>
    <Data>//./root/CIMV2</Data>
    <Data>SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage &gt; 99</Data>
    <Data>0x80041003</Data>
    </EventData>
    </Event>

    Funnily enough the laptop started in normal mode just now!
  6. Route44

    Route44 TechSpot Ambassador Posts: 12,140   +29

    Update McAfee and run a scan. Download the free SuperantiSpyware and the free Malwarebytes and run those as well.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.