Error 1704: Logitech Webcam Software & Issues with C&C3 Uninstall?

By Route44
Feb 10, 2010
Topic Status:
Not open for further replies.
  1. I attempted to unistall the PC game Command & Conquer 3 when this popped up:

    "Error 1704. An installation for Logitech Webcam Software is currently suspended. You must undo the changes by that installation to continue. Do you want to undo those changes?"

    If I clicked "no" the uninstalling ceased. So the next time I clicked "yes" and thus I was able to uninstall. The thing is now my ability to use my Logitech webcam is impossible because the required software has been removed by Windows.

    How is it that this software interfers with a a totally unrelated software so much so that Windows doesn't allow me to move on until I allow it to make changes? My software version on the Logitech installation disk is the latest 1.1.

    Also, twice previously I have had to reinstall the webcam software because everytime it finishes I get a BSOD with an 0xD1 error (which are usually caused by drivers). The second time I had to do it was because one day the software is nowhere to be found! Why? I haven't a clue. This will be the third time I'll have to install this webcam. I have a feeling Logitech refused to pay M$ their asking price of verified drivers.

    I have done some research on Error 1704 and it seems Windows has issues if you don't use their installation program but a lot of software doesn't utilize this program.

    I could use some knowlegeable advice on this one.

    *** I really like the camera and it works great with Skype; now if it only worked with Windows XP Pro with Service Pack 3.
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    Hi Route44 :wave:

    Sounds like quite the pesky problem! I'd start with
    • Windows Installer Cleanup Utility to uninstall/cleanup the Logitech webcam's current installation problem. Note this removes registry entries for the cam from Windows Registry (but leaves files on disk)
    • Then try doing your game uninstall again
    • What Logitech cam model is it? You've also checked their support site for any driver/firmware/application updates?
  3. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    Hey, LookinAround, I was hoping you would look in on this. Thanks. :) The webcam model is C500.

    I have been able to uninstall the game once I said "yes" to the warning from Microsoft (see OP). Prior to that I tried uninstalling via the uninstall option from the game itself, CCleaner, and the Add/Remove option in the Control Panel all to no avail.

    Second, I decided to see what would happen if I only connected the Webcam via USB. Suddenly Online Armor (firewall) wanted to know what I wanted to do with various Logitech software that wanted to load and in a short time the webcam could work and I could also utilize Skype.

    ** So the software was there all the time but it had to be jumped started through Skype.

    Now the latest issue is OA is perpetually flagging the Logitech Webcam Software LWS.exe as a keylogger and no matter how many times I instruct it to Remember My Decision and Allow it doesn't. I even go into the configuration and click allow and no go. Ift never did this before because I have already talked to my inlaws in Mississippi and my daughter in college in Boston (yes, I'm getting old!).

    * When I use the installer you mention what is your suggestion on the C500 webcam drivers.


    Again thanks; it is much, much appreciated.
  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    I may be "reading between the lines" here.. so if you could clarify..

    It sounds like you tried plugging the webcam into a different USB port and, after all the OA prompts, the cam worked? Are you plugging into a port on a USB hub? Or directly to a computer USB port?

    When you say the software disappeared, am i correct to guess that maybe after a reboot you no longer saw the web cam and the cam driver listed in Device Manager? Or what made you think it wasn't there?

    Reasons i ask
    > Windows will often install multiple instances of a USB device driver. One instance for each USB port the device is connected to. So connecting the cam to a different port gave you a new clean driver install on the different USB port that worked
    > Also, by default, Device Manager won't display a device if it's not detected or might display it as something else if detected incorrectly. So i wonder if that's why it might have looked like it "disappeared".

    /* edit */
    You might also want to check you have the latest OA installed. I just happened to read through someone else's post a couple days ago that indicated they updated to a newer version on the OA website
  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    I took a look at the Error 1704 so here's a bit more follow-up info based on what i could find...

    It would seem the Error 1704 results from when an install or uninstall for Product A hasn't completed AND one tries to install/uninstall a different Product B. (as the MS Installer can only handle one product at a time). This case might result if maybe you had tried to
    > Install or uninstall Logitech software
    > Windows asked you to reboot to complete the install/uninstall process
    > You chose not to reboot
    > Then at some point you continued to try uninstall your game (so installer never finished with Logitech)

    Tho i suppose it's also possible if the machine crashed sometime during a Logitech install/uninstall or for any other reason why your Windows registry still has pending data about the Logitech install...(including if the Logitech install process itself was buggy)

    Don;t know if any of this might fit your circumstance / facts in your case??
  6. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    Okay, that makes perfect sense because everytime the software is loaded and then finishes I get an 0xD1 error and on reboot the software is there with Webcam icon and the Webcam works and I can use it in Skype.

    But when I went to uninstall C&C 3 is when I ran into the 1704 error. When I said "yes" to allow Windows to undo the changes is when the Webcam icon disappeaered from both the Desktop and tray.

    By the way, the Webcam driver is there in the Device Manager and from what I gather it should be verified by MS.

    What is really interesting is that neither the Add/Remove or CCleaner have Logitech Webcam on their uninstall list.
  7. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    Yea.... i can guess why you see the above occurring and can give the "tech-splanation" later if you want

    As for the immediate problem: the BSODs that prevent your Logitech webcam from completing a full install.
    > Logitech's v1.1 software is the latest they got for your cam (so no other options there)
    > Which leaves me to wonder about your OA software. I've seen many people post BSODs due to OAdriver.sys

    So
    > Have you looked at your minidumps? Do they point to the same problem file each time?
    > Have you also yet verified you're running the latest OA software version?

    Before you proceed you might want to first backup/image your HD to be cautious. Then
    > Run the MS Installer Cleanup tool (see earlier post for link) . If Logitech is listed, use the tool to clean it up
    > Download and SAVE the logitech install file on your computer
    > Disconnect the cable from the internet
    > Turn off your OA Firewall. Also, look for and be sure to turn off any OA Real time Protection
    > Now run the Logitech installer. Will it run now without BSOD?
    > you can then turn firewall and protection back on and reconnect to interent
  8. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    I will take the steps you suggest. I have thought about uninstalling OA (yes, it is the latest OA version). What is interesting is that thei moment the lws.exe is recognized as Allow in both the Program and Keylogger section of this firewall.

    One other thing, for some unknown reason I can't read my own minidumps because I am flagged as needing administrative privledges?! But I am the administrator.

    Thanks Lookinaround for sticking with me on this.
  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    It could be another sign of OA Real Time Protection interfering when you don't really want it to. Curious if you can access them once you turn rt protection off...
    You're most welcome. I only hope we can find a solution!
  10. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    Okay, here is an update. First, out of curiosity, I tried using Skype by connecting with my daughter in Boston. The mic worked fine but the video aspect would not/could not load. I could see and hear her but she could not see me though she could hear me.

    As a side note she has the same webcam but the Vista 32-bit OS and we had absolutely no issues loading it on her system the very first time.

    Second, I downloaded and installed the Windows Installer Cleanup Utility but nothing Logitech was on the list anywhere. I really took my time going through the list 5 separate times. However, RegCleaner does list Logitech Software. The only issue here is that a) I know to be extremely cautious when dealing with the Registry and b) I do have a Logitech Mouse and not all the items are clear on differentiating the two.


    After further research Logitech does provide very clear and concise steps on how to Boot Clean in Windows XP for such issues as I am experiencing. Plus, I was able to download the software for this webcam and save it to my desktop.

    Question: I found the folder for the Webcam. Should I just delete this and start over that way?
  11. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    OK. If not listed in the Cleanup tool it should be ready and OK to attempt reinstall. (As i understand it, the tool makes sure all the registgry keys for MS Installer stuff is cleaned up.), So i wouldn't worry if still other reference still found by RegCleaner.
    I'd be inclined to rename it (vs. delete it) just in case..
  12. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    Okay, then I will rename it and let you know how it works out. It may take me 24 hours to respond due to responsibilites but one never knows. Thanks.
  13. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    *Sigh* Okay, I used the WICU as previously posted. Then I followed these directions from Logitech:

    To Boot Clean in Windows XP

    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Process SYSTEM.INI file
    4. Uncheck Process WIN.INI file
    5. Uncheck Load Startup Items
    6. Click on the Services tab
    7. At the bottom, check Hide All Microsoft Services
    8. Uncheck all boxes in the window or click the button labeled Disable All
    6. Click OK
    7. Click Restart


    After performing the necessary steps, restore your system by doing the following:

    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click OK
    4. Click YES, when asked to restart your computer

    > OA was disabled

    > I installed the full software from the download I was able to get from their website.

    > ...and at the end of installation another 0xD1 BSOD error.

    * So it rebooted and I set things at normal setup and I am still not able to read my own minidump even though I am the administrator.

    *** But the webcam/software works and the icons have returned.

    Don't know what else to say. If I have anymore issues I'll let you know. Thanks much for all your help.
     
  14. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    Argghhh.. I feel your frustration! But I'm glad you thought to copy/paste the instructions from Logitech because I see their instructions include a critical but poorly written sentence

    /* EDIT */
    Ooops.
    After re-reading your post, i think you did, in fact, do things in the order as intended. My original post continues below - though now not sure that it really applies for you. In any case, will follow-up with more sometime later
    /* End of Edit */
    When Logitech says "After performing the necessary steps," they mean "now is the time you should try to reinstall your webcam". So, if i read your post as being in the sequence you did things(?), then you retried the Logitech install AFTER you restored your boot settings

    Try this (and make sure you already have the Logitech downloaded install file)

    First part of Logitech Instructions

    1. Click Start --> Run --> Type MSCONFIG --> Click OK
    2. On the General tab, choose Selective Startup
    3. Uncheck Process SYSTEM.INI file
    4. Uncheck Process WIN.INI file
    5. Uncheck Load Startup Items
    6. Click on the Services tab
    7. At the bottom, check Hide All Microsoft Services
    8. Uncheck all boxes in the window or click the button labeled Disable All
    6. Click OK
    7. Click Restart

    Add these steps here
    On restart, click OK, OK, Exit without Restart to the pop ups you'll see. Then
    1. Open Add/Remove Programs. Look for the Logitech webcam (i think it should be in there now). Uninstall it. Does it uninstall without problem?
    2. Open MS Installer cleanup tool and check again logitech isn't there
    3. NOW, run the Logitech installer. Does it run OK or still BSOD?

    Now we resume Logitech instructions to restore your system by doing the following:
    1. Click Start --> Run --> Type MSCONFIG--> Click OK
    2. On the General tab, choose Normal Startup
    3. Click OK
    4. Click YES, when asked to restart your computer
  15. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    1. Try taking ownership of the minidump files
    2. When you said OA was disabled, did you specifically look for/disable any OA realtime protection? (i.e. not just the OA firewall)
    3. fyi.. i saw somewhere for OA you need to set Trust Control (as well as Allow) for lws.exe
    4. Are you running any other anti-malware product that might have real time protection enabled? (e.g. Spybot Teatimer?)
  16. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    Lookinaround: been out of state all day and just returned this late evening. Will give a go with what your last two posts provide. Just wanted to give you an update.
  17. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    Hey LookinAround, sorry for the delay. My other system's Ballistix memory decided to become corrupted, 3 out of 4 sticks, and Crucial can't replace them but they are sending four brand new DDR 400 1 Gig sticks in exchange for my 4x512.

    So I wound up spending a whole lot of time running memtest, etc.

    Anyway, I decided to follow your instructions tonight and after Step 7 I get this message: "Access denied error was returned while attempting to change a service. You may need to log on using an administrator account to make the specified change." I forgot that this happened last time but I restarted anyway. Duh!

    But as I said, I am the administrator unless something is really wrong. Advice please.
  18. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    I've seen this before (on my own computer). You must have an HP printer. You'll need to hack your registry to disable the PML service for now. See here

    Also, a technical point helpful to understand about Admin

    Being Admin doesn't automatically give you permission to access all files/folders/processes etc. The file/folder/process's security permissions control access by user (including Admin) which is why you need to do things like How to take ownership of a file or a folder in Windows XP.

    Simple example is your system restore folder. By default, Admin is not allowed access. Look at C:\System Volume Information. It will show size 0 and you can't open it UNLESS you take ownership and add Admin to its security permissions.
  19. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    Man are you ever correct. I do have an HP Photosmart printer. You must be psychic. ;)

    I fully understand what you linked me to with just one question: When I manually set PML Driver HPZ12 to manual what does this do to the functioning of said driver as compared to disabling it (which I won't do)? I did research but I found nothing definitive as to what to expect that will be different than what I experienced with it set at auto.

    Thanks.
  20. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    If Service StartupType=
    > Automatic - Windows loads the service AND starts the service at Windows startup
    > Manual - Windows only loads the service at startup. It's started "on demand" (i.e. not until the first time something needs it)
    > Disabled - Windows doesn't load the service. It can only be started if StartupType is changed and Windows rebooted

    Another interesting point:
    > i just noticed my machine no longer has that problem you have with msconfig
    > So i wonder if you might have an old HP driver loaded?? (I just installed this machine about 4 months ago)

    > Try doing the clean boot install without getting the msconfig error msg
    > If you still get BSOD you need to take ownership of your minidump and read it
    > You also haven't indicated if you're sure all real time protection is turned off in all your anti-malware products. Is important 'cause
    ...1) I've seen cases of real time protection interfere and cause BSODs
    ...2) I could guess the rt protection might be a reason your minidump files end up without permission for you to view it

    Those are all my best guesses
  21. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    Just for curiosity's sake I asked HP about setting the PML Driver HPZ12 to manual. Long story short (they wanted to know who, what, and where I was directed to do the MSCONFIG, etc.) and their conclusion is its not their driver.

    Anyway, I am going to disable, OA, SAS, and NOD32 before the MSCONFIG and then take it from there...
  22. Route44

    Route44 TechSpot Ambassador Topic Starter Posts: 12,109   +21

    LookinAround, sorry for another delay but I was finally able to implement the enhanced Logitech directions you gave me. But first, just for clarification, on previous occasions I didn't try to install the software after I renabled the boot.ini.

    Another interesting thing is that before my most recent attempt the Webcam Logo and drivers completely disappeared from my PC -- twice. Microsoft just didn't like it.

    Anyway your were dead on about security software probably being the cause because I disabled NOD32, SuperantiSpyware, and Online Armor from Real Time Protection and then I followed your directions. (I didn't have to deal with the HP driver but I planned on doing so if this time it didn't take)

    The software installed without a hitch though the Windows Wizard Installer kept popping up which I had to cancel every time because Logitech has its own installer.

    * No BSOD and I actually came to a screen I didn't see before because of the previous BSODs.

    Again, much, much thanks for your patience. I learned at least three new things from you that I hadn't known before and it is always a good day when you can learn at least one new thing.
  23. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,279   +152

    Glad to hear it finally worked! Hope you're successfully cam'ing with your daughter now. :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.