TechSpot

Error code 0x80070057 while trying fresh Win 7 install

By Mazrim
Aug 20, 2011
Post New Reply
  1. Hey everyone! I just bought parts for a new system build:

    AMD Phenom II x6 Thurban Blk Edition 3.2 Ghz
    16 GB Corsair Vengeance PC 1600
    ASUS M4A87TD EVO mobo
    Nvidia Geforce 560 Ti 1GB Gfx card
    Sony Optiarc 56x CD/DVD rom (SATA)
    WD 2TB 7800 RPM HD (SATA)

    After piecing everything, it fired right up so I went into BIOS and set the boot priority for DVD rom > HD. Placed my windows 7 64 disc in, saved and exited, and things seemed to go ok until windows gave me the error code mentioned in the title of this thread.

    "Windows could not format the partition on disk 0. The error occurred while preparing the partition selected for installation. Error code: 0x80070057."

    This error shows every time I try to install Win 7. The HD is brand spanking new, and I did click the "new" option in advanced settings to set and format a partition.The REALLY weird thing is that when this happens, my bios settings reset back to default values!

    Why is this happening? Do I have a bad motherboard? Bad HD? Bad OS disk? I don't have duplicates of anything so it's impossible to troubleshoot by elimination. I really don't know what else to do now, I'm close to giving up on this system and just sending everything back to Newegg and cutting my losses.

    Any advice would be golden at this point, thanks for any help you guys can lend!

    *UPDATE*: I swapped SATA cables, ran the in house mem diagnostic (found no errors), even tried dfferent SATA ports on the mobo, and I still get the same results. Things seem to be getting worse, however. Now windows sometimes doesn't even detect the drive, so to eliminate the possibility that the drive was DOA, I swapped to a known good drive, and I get the exact same result when attempting to either create a new partition, or format the existing one.
     
  2. Mazrim

    Mazrim TS Enthusiast Topic Starter Posts: 109

    UPDATE#2: Problem resolved! The issue was with the CASE. They installed a "hot - swap" device that you hook your HD into, but the interface was bad, and was corrupting any and all data that passed through.

    BUYER BEWARE: the case is an Azza Hurricane 2000 BLK. Anyone who uses this case in a system build REMOVE the hot swap interface cards that are installed in the drive bays, as they do not work as designed. I hope this helps anyone building a system that might be running into a similar problem.
     
  3. supertech

    supertech TS Member Posts: 83   +10

    I just had this problem with a clients' brand new system similar to yours. It was bad SATA cable (brand new, Asus branded). The funny part is that I installed with a same cable on a 500 GB SATA drive but it was ok but with the 2TB drive, it was displaying this message.
     
  4. Achilles John

    Achilles John TS Rookie

    Dear Mazrim;
    It is likely that the hard disk that you bought which is new of course is I'm 100% sure defective. Try to bring it back to the store where you bought it have it replaced for warranty. As for others who has the same problem, try to do same and see if this fix the problem.
     
  5. mailpup

    mailpup TS Special Forces Posts: 8,456   +228

    Achilles, you should read the thread more carefully. Mazrim already solved his problem 2.5 years ago and it wasn't the hard drive.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.