TechSpot

eSATA drive not recognized

By boncuk
May 19, 2010
  1. Hi,
    I just bought an external hard-drive which has e-sata and usb 2.0 connectivity options.

    I was planning to use e-sata when connecting to my desktop pc and using usb when connecting to a mediaplayer device.

    So, when I plugged in this drive to my e-sata port, I was expecting it to work like an usb drive, like a pop-up at the system tray letting me know a new drive was found and that it would disappear when I would put the drive off. But this didn't work, windows didn't recognise the drive was there or connected. I checked the internal cable in my casing, there was a cable from the mobo to this external port. So I tried powering up my pc while this drive was attached and on. This time windows found the drive but as if it was an internal drive, meaning, it showed up in windows explorer as a fixed drive, but no system tray icon or the option to eject it. So when I put the drive off, it didn't disappear, as if it was still connected.

    I googled a bit and found out that there is an option in the bios to change your sata drives from ide to ahci. Took me a while to switch to ahci, because stupid windows didn't boot up when this was changed. Options are to reinstall windows after this switch or to fool around with drivers and registry settings (see: hxxp://forum-en.msi.com/index.php?topic=106575.0 also worked for asus mobo)

    I saw that ahci isn't per se better than the ide setting, especially if you're not an advanced user, but ahci makes hotswapping possible, so I assumed that hotswapping was the cause of my problem and once I would switch to ahci, my problem would be solved.

    But the drive still doesn't work like I want to, When I connect it and put it on, windows still doesn't 'find' it, like it finds usb drives. I have to go to device manager and right click somewhere and choose: 'scan for hardware changes'. Then windows DOES find it.

    So, anyone knows where the problem might be. I think from my story this can be concluded:
    - it is not connection related, as the connection works once windows finds the drive
    - it is not a faulty drive, as I copied many gb's to it once the connection was established, with usb AND esata cables.
    - it must be bios or windows related, but which I don't know.

    A second problem arose once I changed to ahci mode, namely: my internal hd's now show up as removable drives, is there a way to tell windows that those drives are actually fixed and only the one connected to the 6th s-ata port is removable, which is connected to the external sata port?

    Also, there are six s-ata ports for internal hds, which are ich10r, the e-sata port was connected to port 6, which was done by the person who built my pc at the shop. But there are two more s-ata ports on my mobo which are called Silicon Image Serial ATA RAID connectors. Those have a different color from the first 6. So is the e-sata connected correctly to the 6th sata port, or should I use one of these two?

    I have an asus p5q pro motherboard with windows 7. 4 internal hd's without raid and I have everything at the default settings, no overclocking or anything like that.

    So, what I want is to make the esata port work like an usb port, when I plug in the external drive and power it on, I want it to be recognised by windows and to disappear when I switch it off.

    Thanks in advance for the help.
     
  2. captaincranky

    captaincranky TechSpot Addict Posts: 11,055   +970

    Sadly, "switching horses in midstream" so to speak doesn't work, and the OS must be reinstalled with "ACHI" selected at the outset.

    I think this thread is essentially the same issue; http://www.techspot.com/vb/topic144050.html Have a look.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.