Excel Web Queries Broken

By EyeSore
May 24, 2015
Post New Reply
  1. Excel (versions 2007 – 2010 tested on WIN7) no longer are able to perform web queries. This has been broken since about Nov 2014. I have tested queries on multiple machines including machines maintained by others.

    Simple queries return, a script error when the webpage is opened,
    Script Error
    An error has occurred in the script on this page.
    Line: 1
    Char : 198
    Error: Not implemented
    Code: 0
    Do you want to continue running scripts on this page?

    If I manually respond to the questions, the next message,
    This document contains embedded content that may be harmful to your computer.
    Choose from one of the following options:
    • Do not allow content to play (Recommended)
    • I recognize this content. Allow it to play.

    If I continue manually answer the questions a query is imported but results in message,
    The file could not be accessed. Try one of the following: …

    Most web pages cause these types of error. If I open the same webpage using IE-11, etc., I get no errors. I have searched on the web and am not seeing a solution. It almost seems like few people use web queries.

    Help solving restoring Excel web queries would be appreciated. Alternatives to Excel will be considered.
  2. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    Can you be more precise; Is this just accessing some URL in the spreadsheet OR is it the OBDC data mapping pulling external data (and if so, is a mapping of a local file, a network share or omg, truly internet data somewhere in the world)?
  3. EyeSore

    EyeSore TS Rookie Topic Starter Posts: 52

    All URLS seem to be broken. I use web queries for accessing stock data. You can try this specific URL.,MSFT

    This will list AAPL and MSFT stock values. Try selecting and importing stock values. This does not work for Excel 2007 or 2010. I get the webpage, the warning, and a script error, when setup this query.
  4. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

  5. EyeSore

    EyeSore TS Rookie Topic Starter Posts: 52

    Correct. Did you test it?
  6. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    YES - - works for me but notice:
    • I disallow BING from all browers
    • I am using OpenOffice 4.1.1
    Did you try accessing the broken javascript (ie the cause of the error)
    IMO, it's not Excel but rather your browser configuration
  7. EyeSore

    EyeSore TS Rookie Topic Starter Posts: 52

    If the ticker test works on OpenOffice I may try it. The browser works fine when direct to the same sites as the query. Unless you tested Excel we do not know if the browser configuration is broken. Did the ticker query covered in my last post work? The Bing test fails because that is the default location or IE11.
  8. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    Kind of makes my point then doesn't it - - Browser Specific

    Yes,,MSFT works as a regular URL in a browser
    AND as a LINK in a spreadsheet.

    Pic a browser other than your default, disable BING and paste into the URL.

    Then set that as the default browser and close it. Now click your Excel Link - - bet it works.
  9. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    Follow-up: It also works in IE11
  10. EyeSore

    EyeSore TS Rookie Topic Starter Posts: 52

    I am not following what you are saying.

    1) What do you mean disallow Bing from all browsers?I changed my IE11 home page away from BING.
    I disabled the BING search engine in my default FireFox browser.
    There is no BING listed in running programs or as an installed program.

    2) Excel appears to be tied to IE. Is there a way to force it to use FireFox?

    3) What browser configuration needs to change?

    I still get the same query errors after changing the default page. I appreciate your help but need more details on what you are doing to get Excel working.
  11. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    Look in the IE browser options
    Click the GEAR (upper right)->IE Options->Add-Ons->Search
    disable both Search values.

    IE Options->Programs clear[ ] check default browser.

    Firefox->(three bars upper right) -> Options->General [x] Always check if Firefox is your default browser

    While it is possible that Excel is invoking IE, usually programs access the default browser.
  12. EyeSore

    EyeSore TS Rookie Topic Starter Posts: 52

    Thanks for the extra details.

    I disabled IE “search suggestions” and “Top result” for Bing. The IE check for default browser was already disabled. The FireFox “Always check if Firefox is your default browser” was already checked. I rebooted my machine.

    I redid the Yahoo tick query and it failed in the same way. I get an additional security certificate warning.:(

    The only IE add-on enabled is Microsoft Research. I disabled that too but web queries still fail.

    Is there anything else I should check or change to get web queries working?
  13. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    Beats the heck out of me; Sorry, I'm out of ideas.
    Last edited: Aug 23, 2015

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...