External hard drive does not appear in 'My Computer'

By xenniex
Sep 5, 2010
Post New Reply
  1. Hello everyone

    I am having issues with my 500 Gb IOMEGA external hard disk

    I have been using this HD for a few months now and it has been working perfectly until this morning. I copied a folder from my PC to my external hard disk. After reaching abuot 75% of the copying process an error occured. The copying stopped and my hard disk was no longer in the 'my computer' folder.

    I tried reconnecting the hard disk. The Pc sais it recognizes a new hardware, it isntall it and sais that it is ready to use. But in reality the HD does not appear in 'my computer' and i can't seem to find it anywhere.The ahrd disk also doesnt appear in the 'disk management' section (right click 'my computer -> management -> disk management)

    After that i tried the hard disk on my friends computer and it also didn't work. It recgnizes the hardware and install sit but we can't find it!

    - I have an ASUS laptop with Windows XP installed.
    - I did not drop the hard disk or do anything to harm it, (I don't think it is broken)
    - I also tried removing the upper and lower fileters from the windows registry, This also did not help.


    Please help. It would be greatly appreciated!

    - xenniex
  2. hughva

    hughva Newcomer, in training Posts: 309

    Are you sure it's not in Disk Management, maybe as an unformatted drive?
    If so, either the case, the cable or the drive has failed.
    Try removing the drive from the case and connecting it.
  3. xenniex

    xenniex Newcomer, in training Topic Starter

    I am sure it is not in disk management. The little led lamp on my hard disk shows that it works, and my pc sais that the disk is working correctly. Yet i can't seem to find it anywhere. Please, i really need help! Thank you
  4. hughva

    hughva Newcomer, in training Posts: 309

    Try removing the drive from the case and connecting it.
  5. xenniex

    xenniex Newcomer, in training Topic Starter

    i opened the hard disk and removed the cover. Then tried pluggin it in again, Unfortunatly i am ending up with the same results. Do i maybe have to update the drivers or soemthing. I am sorry i really don't know much about computers. If you can't help me,i don't know who can.

    Thank you for your time, i do appreciate it!
  6. hughva

    hughva Newcomer, in training Posts: 309

    How did you connect it?
    It has to be connected directly to the motherboard, put into another case or attached via USB adapter.
    Does the drive spin when connected?


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.